APK file and Companion isn't same

I don’t know how to describe this. Let me try.
I made some block codes. Like that:

It works fine with the companion but when i download the APK file, it opens everything in the browser even the link i censored in the screenshot.

How do i fix this?

Hi @Mehmet_Ak,

This issue is likely because of you using the math comparison block, and not the boolean comparison block which is, in a way, “universal.”


:octopus: Nathan

1 Like

from the documentation MIT App Inventor Logic Blocks

Acts exactly the same as the = block found in Math

I’m not familiar with that event ProgressChanged…
I would try another event, for example PageLoaded or use a Clock component together with the Clock.Timer event


Well, that worked. In a way. My main site is in the program yeah. But everything i click leads me to the external browser.

If you want to see the site in your app just chnge the webviewer property Use External Browser to false

It’s already closed. Let me try to rephrase. For example i have a site called test.kodular . From that site, i can go to test.kodular/1 . When i put the site into the app, test.kodular opens in app but when i want to go to test.kodular/1 , it directs me to external browser. Not only that, every link-included buttons directs me to the app except the main page. How do i fix this?

Or else you can also use activity starter

Why have u added the block for use external browser to true when u don’t want it

Nice question. There is a “share” button in my site. I just want the “Share” button to open in external browser. There are Facebook, Twitter, Pinterest and Blogger E-mail share. I just want them to open in external browser.

But share will open in respective apps not browser…

You may use this method if it still opens in your app webview :point_down:


Just add those specific websites in the if condition which you want to open in external browser

That’s the problem. They open in my app. Not their own programs or in external browser. I want to fix this. They open in my app. And login screen comes.

Even that didn’t work. I don’t understand what i’m doing wrong. They still open in web viewer. I use blogger as my website. I write game reviews there. U know u can share blog posts. And the share links still open in web viewer.

Try this :point_down:

blocks (1)

Video was cropped at last due to presence of some personal info

That worked. Thank you so much.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.