.apk same android version one works and one doesn't work, please help me (.aia inside), curl doesn't work?

Good evening, do you know after years of experience in the world of information technology, a new challenge presents itself, something inexplicable? here this is the case, follow me…
if I launch the same .apk (curl) with android 11 (both vr or phone with flip3) I can get the answer, if the same apk, I run it on tab A8 (android 8.1) the curl does not give me the result (same net)
convinced that I have an API problem today I bought an android tab 8 (android 11) but I have not solved anything same exact problem, please help me I don’t know what is happening …

I give you the .aia file, on flip z3 and NOX it works (you just have to press the “GET” button to get the result), on my other devices it doesn’t … :frowning:
I can also recognize you some money for the time you waste for me (if I don’t meet some forum rules, I apologize in advance and take away what has been said)

curl.aia (15.0 KB)

ok, in the meantime I have made progress, and I communicate them to those who perhaps have the same problems as mine without explanation (for weeks) it seems that the “curl” must be present within the android system, unfortunately it seems that not all android (also if version 11) are equipped with it. unfortunately it becomes difficult to understand which device has curl and which device does not have curl, I did not understand if curl can be added …?

As the developer already mentioned

But you can try this, using web component

curl_1.aia (15.3 KB)

I used curl to blocks by @Jerin_Jacob to create procedure

1 Like

I tried it, unfortunately it doesn’t work, a virtualizer is probably often used, but in devices the curl is usable in very few devices
do you have another solution ? months of work almost thrown away :frowning:

Have you tried ?

I tested the file you attached to me, it gives me the known error: 1101 unable to get a response withthe specific URL "
I ask you who have more experience than me, but are you sure that the “curl” (or with the KIO4_Terminal or Web method) work correctly on a physical device?

May I ask what are you trying to do with this command ?

curl -v -X GET -H 'Version: 14.0' -H 'Accept: application/json' -H "" 'https://www.google.com'

it was a simple test to see if the curl answered me, in the attachment I put the correct .aia, see that it works on virtual, but there will be no way to make it work on the device, this is because from the terminal (on device) curl is not installed
CURL OK.aia (15.1 KB)

To see if curl is installed or not simply use shell component


sure you can also see it in your method, but few devices have the curl installed, how can you solve it?
the important thing is to be useful aware that the Curl only works in virtual, on android devices it must be installed na (usually a top device), I hope it can be useful to someone and avoid wasting entire months programming and then doing this discovery … all my work is to be trashed :frowning:

You can not I believe, but more qualified to solve your questons about curl is the developer of terminal extension @juananton1991

thanks for the support and for the contact, I am available to carry out tests etc …

Hi everyone, I was able to find a solution to “curl” from devices that have not installed it, and I want to share it with you, the curl as other features of “elite” are only installed on high-end android devices.
in order to get the curl you must have the root “magisk” (I will not put the link there because it is forbidden by the forum policy), once the root is obtained:

  1. Download & Install “BusyBox” from Makisk Repo
  2. Download & Install “Cross Compiled Binaries” from the Magisk Repo
  3. Reboot
  4. Open a shell and get an su
  5. Run “ccbins”
  6. Select “Install a Binary” ie “-> 6”
  7. Install “curl” → 8 "
  8. Reboot
  9. open a shell, get su and curl is now available

Now you can use KIO4_Terminal (cURL) with a device !!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.