App Closes Automatically on Start

I have been facing this issue from couple of days, I have been working on this project for long time and I never got any issue.
But since I want to update my existing app, I changed the version code and app crashes on start.
App works fine on companion but it crashes on installed apk

I am attaching the error code that I received, Request the community for help to solve this.

Note : I already read all the existing post and tried but couldn’t solve my problem, so I am creating this new topic, So I request moderators not to unlist.

java.lang.NoClassDefFoundError: Failed resolution of: Lcom/google/appinventor/components/runtime/repackaged/org/json/JSONArray;
at java.lang.reflect.Executable.getMethodReturnTypeInternal(Native Method)
at java.lang.reflect.Method.getReturnType(
at java.lang.Class.getDeclaredMethods(
at gnu.bytecode.ClassType.addMethods(
at gnu.bytecode.ClassType.getDeclaredMethods(
at gnu.bytecode.ClassType.getMethods(
at gnu.kawa.reflect.ClassMethods.getMethods(
at gnu.kawa.reflect.ClassMethods.apply(
at gnu.kawa.reflect.Invoke.lookupMethods(
at gnu.kawa.reflect.Invoke.applyN(
at gnu.mapping.ProcedureN.apply2(
at io.kodular.syedmuzakkir65.DentalCompanion.Screen1.$define(Screen1.yail:10250)
at android.os.Handler.dispatchMessage(
at android.os.Looper.loop(
at java.lang.reflect.Method.invoke(Native Method)
Caused by: java.lang.ClassNotFoundException:
… 30 more

Please read here ,

Too many arrangment and labels :woozy_face:

It is not recommended to use extensions from Deep Host.

What does the code mean??

I don’t think this file is present in app inventor.
So I can’t help more.

Why does companion doesn’t give any error then ?

Is there no one who can explain the error code above ? ?

Remove permission blocks its working fine. Yesterday i also fetch same problem. I thing there is something buggy in permission block. its some time works some time not if you clear app data then its open 1 time and after same auto aromatically close

Didn’t worked

java.lang.NoClassDefFoundError: Failed resolution of: Lcom/google/appinventor/components/runtime/repackaged/org/json/JSONArray;

Which component has this class

This class does not exist in App Inventor.

Can it be extension??

No, extensions can’t have that package name.
Try removing Deep Host’s extension.

I didn’t understood, I am not into java

Share the aia and / or APK.

JSONException is a class of org.json jar but gets refactored to
It seems.
Originally it does not exists in runtime package.

It can be because of Image Utilities or Graphic Design extension.

Nothing suspicious except that error is occurring on Screen Initialize becase of an extension/ imported component.

:open_mouth::open_mouth: OMG what is that, what am I doing wrong