App closes when I click a button

Does anyone here have an idea what’s the problem of an app where it closes after clicking a button. When I click the “reserve” of my app it automatically close. I don’t know if it is a bug or something. I even tried it in companion and it didn’t work too. Download the apk file in this link to check by yourself.

Thank you for your time.

This post was flagged by the community and is temporarily hidden.

1 Like

Instead you can provide related blocks image and a Screen-recording maybe showing where exactly is the problem.

Also no one can download it because file is in Trash

1 Like

Without any proof or screenshot of your aia or source file, no one can suggest you

But make sure that your have checked the globally pinned post first and checked all the fileds property as per suggested in the topic else check your logic when you click the button.

Make sure the logical sequence is fixed firmly else app will behave like that only

Okay sorry guys, this is my aia.
AMOEC_Transpo_Revise.aia (7.3 MB)
Until now its still not working.

One of the spinner’s Elements from string property field is empty in Reservation screen

IMG_20220320_111612

2 Likes

Did you read this? We always recommending the @Anu guide (pinned as global post in community) to one all if anyone says app closes or exit on screen initialise or button click

2 Likes

I tried the suggested solution last night but it also didn’t work. I also didn’t noticed the empty part. Sorry

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.