App is crashing killing Activity

Hello, i’ve created this app a few months ago, and i had no problems, i made an update with the latest version of Kodular Creator, and now sometimes my app crashes and sometimes don’t but it only crashes in some devices.

I’ve used log cat (adb logcat | find “packagename”)
The device is an Amazon Fire 7 9th generation tablet.
and got this:

01-08 12:48:32.572   598   827 I ActivityManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 cmp=com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1} from uid 10081 on display 0
01-08 12:48:32.642   598  1748 I ActivityManager: Start proc 13219:com.ical.pruebasordenes/u0a156 for activity com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1
01-08 12:48:32.677   598   637 D AmazonWindowMetrics: On window event - Package com.ical.pruebasordenes, isDreaming false, state 1, alexaMode 0
01-08 12:48:32.718 13219 13219 W System  : ClassLoader referenced unknown path: /data/app/com.ical.pruebasordenes-2/lib/arm
01-08 12:48:33.014 13219 13219 I art     : Caused by: java.lang.ClassNotFoundException: Didn't find class "android.view.View$OnUnhandledKeyEventListener" on path: DexPathList[[zip file "/data/app/com.ical.pruebasordenes-2/base.apk"],nativeLibraryDirectories=[/data/app/com.ical.pruebasordenes-2/lib/arm, /system/lib, /vendor/lib]]
01-08 12:48:34.480 13219 13219 E AndroidRuntime: Process: com.ical.pruebasordenes, PID: 13219
01-08 12:48:34.488   598   619 I ActivityManager: Displayed com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1: +1s857ms
01-08 12:48:34.496   598   637 D AmazonWindowMetrics: On window event - Package com.ical.pruebasordenes, isDreaming false, state 1, alexaMode 0
01-08 12:48:34.562   598  1748 W ActivityManager:   Force finishing activity com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1
01-08 12:48:34.603   598   638 W InputDispatcher: channel '83feb7b com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1 (server)' ~ Consumer closed input channel or an error occurred.  events=0x9
01-08 12:48:34.603   598   638 E InputDispatcher: channel '83feb7b com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1 (server)' ~ Channel is unrecoverably broken and will be disposed!
01-08 12:48:34.609   598  1748 I ActivityManager: Process com.ical.pruebasordenes (pid 13219) has died
01-08 12:48:34.610   598  5859 I WindowManager: WIN DEATH: Window{83feb7b u0 com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1}
01-08 12:48:34.610   598  5859 W InputDispatcher: Attempted to unregister already unregistered input channel '83feb7b com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1 (server)'
01-08 12:48:34.624   598   748 W Eve     :   top=com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1 launching=false
01-08 12:48:34.625   598   748 W Eve     : Lmk did not kill com.ical.pruebasordenes
01-08 12:48:42.679   598   620 I PackageRecency: Intent triggered to package: ComponentInfo{com.amazon.kindle.cms/com.amazon.kindle.cms.MaintenanceService$PackageRecencyListener} for Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 cmp=com.ical.pruebasordenes/io.kodular.icalogytech.Global_Ordenes.Screen1 }

I don’t know if it is related to blocks error or if it is an extension problem.
Before updating it had no problems,
the only things i added are:
KIO4_Install Extension
Device Utilities Component
Download Component
And now i use Screen1.Version Code

And here’s a picture of the added blocks

Thanks for your help…

PS: I’m aware that in order to install apps in API 26+ i have to add the in the manifest, i didn’t do it, that’s why i validate the api version the download is complete if is less than 26 tries to install the app, if is greater or equals 26 it just shows the download.

Also i don’t know if it is a bug from the DeviceUtilities component trying to get the API version because of Amazon’s FireOS

If the kodular already have the components for which you are using extension then you can’t use that extension .

Problem solved, if someone has the same error is due to adding Firebase go Offline block on Screen Initialize event