App that usually worked fine stops just at launch after some improvements

Hi Koders!
I have an app that works fine, it is on Google Play, with a moderate (blink, blink) success.

I made some improvements, added some elements and some blocks and try to test it with the apk file, before uploading it to the Play Console with the abb file, like I always do.
The apk is generated without problems, but when the app is started, this message appears:
When tested with Companion no error is shown. There is no errors either in warnings in the blocks tab of the creator.
The previous aia file doesn’t have any problem and the apk and abb files worked fine.
I have no idea where to start looking.
I tried to find the problem using adb, but I can’t find where the problem is, this is so much for me. I paste here two captures of the logcat, the log was quite longer but I don’t know how to save it from the cmd.
The changes in the new version are a few, so if somebody can tell me how to fix this It would be so appreciated. If not, I’ll try to make all the changes over the old version and see what happens.

One curious thing is that if I try to generate the apk file with an error in the warnings, the apk is generated without problems, and that’s not what usually happens.
Any help is welcome.
Thanks in advance.

Already it is discussed and gave suggestion also in brief manner in the globally pinned post


Please next time provide txt file of your crash log as your images above doesn’t say anything about your crash…

Catlog_Zagal.txt (536.5 KB)


Hi. Thanks fot the answer. I’m not using most of this components and the ones used have this texts filled. Almost everything in the app was used before and doesn’t had problems.

Thanks Boban.
How can I get that txt file?

You can simply save the output to a text file easily by appending > filename.txt at the end of the command. For example, adb logcat > log.txt. You can do adb logcat -c before to clear the log file if possible.


Thanks so much.
This is the log.txt file I got after starting the app and appearing the stop message.
Please somebody can tell me where is the problem? The log file is like chinese to me.
log.txt (4.3 KB)

java.lang.RuntimeException: Unable to start activity ComponentInfo{com.yogasessions/io.kodular.jcmarquitecto.Yd06.Screen1}: /tmp/1631962170080_0.05765140660899937-0/youngandroidproject/…/src/io/kodular/jcmarquitecto/Yd06/Screen1.yail:2404:83: unbound location null

This line is in almost all projects which are crashing due to empty text fields.

Did you checked whether all text field of components are not empty ?

1 Like

I did with the componet you listed in this topic:

But I’ll do it again with all the components.

1 Like

Check all the components present in Screen 1 and don’t forget to check About Screen Title.

1 Like

I’ll do it. The thing is that almost all the components were in previous versions and never had this problem, and the new components are only labels, card views, horizontal and vertical arrangements, spaces and check box.
Anyway, I’ll look and see.
Thanks again.

1 Like

Weird, I got totally different output from his app on Android 5.


I have no idea, sorry. The log I posted is from a device with android 7.7 and I tested the apk with another device with android 6.0, a tablet, and the problem is the same.

Hai Friends my apps crash too…

I’m trying logcat and find this

09-19 16:06:50.379 32706 32706 W Class com.squareup.picasso.Picasso failed lock verification and will run slower.
09-19 16:06:50.381 32706 32706 W Class com.squareup.picasso.UrlConnectionDownloader failed lock verification and will run slower.
09-19 16:06:50.382 32706 32706 W Class com.squareup.picasso.LruCache failed lock verification and will run slower.
09-19 16:06:50.383 32706 32706 W Settings: Setting airplane_mode_on has moved from android.provider.Settings.System to android.provider.Settings.Global, returning read-only value.
09-19 16:06:50.387 32706 580 W Class com.squareup.picasso.BitmapHunter failed lock verification and will run slower.
09-19 16:06:50.389 32706 32706 D AndroidRuntime: Shutting down VM
09-19 16:06:50.389 32706 32706 E AndroidRuntime: FATAL EXCEPTION: main
09-19 16:06:50.389 32706 32706 E AndroidRuntime: Process:, PID: 32706

what component make that crash?

The thing is getting worse.

I made the apk with the previous version, the one before the improvements, and the results is the same.

This version of the aia is the one that the aab file for the Google Play Store was generated with. Previous apk doesn’t had any problem before.

I tried also with a copy of the aia stored in my computer, with the same result.

I tried with much older versions of the aia, with the same result.

I tried with a different project not related to this app and the apk works fine.

Maybe the project is corrupt in any way?

This may be relevant or not, but the name of the app have extrange characters. I thought it was caused by the accent in Yogadú, so I erase it, but this characters keeps appearing.

I left here the log of the device with the previous apk, the one that worked fine just a week ago.

Please, any help will be more than welcome because it seems that I’ve lost the whole project.

log.txt (9.6 KB)

This is new situation. All my app now when i extruct apk without any chabge from previous working project they crush on initialize so i think problem is within kodular

1 Like

Hi again.
Following what is said in this post:
(the post is flagged, maybe because its written in spanish) I found that the Consent Message and Consent Title of the AdMob elements where empty. Filled them with some text and the app didn’t crashed!
Looking for the empty fields with that method is reliable.
Anyway I think Kodular should find a better solution to this than fill useless element’s fields with text.