Bad Argument To Create

When I run my app sometime this error appears. It does not come every time. I have go through the community but did not found any solution.

I assume you are using Dynamic Components Extension which made by me.

Looks like your first parameter which is the “in” parameter is blank, because in the error it says [*nothing*]. So you need to fill all sockets to make it work.



Yes, I am using your extension. But there is no blank parameter in it. I checked it twice.

App Inventor says there is a blank parameter itself, not the extension. Can you post your Create block so I can determine what’s going wrong?

i will pm you

I would prefer posting it here because so everyone can understand it and I’m not asking for all blocks, just the Create block.

ok, Here it is . This block causing error:

Move the variable setter to the first place and set the id parameter to only “P_Apps_ID” block. (I mean remove the math + 1 block there)

i used this method in many projects, and it worked. Somehow i will try this also.

Thanks for your help… :smiling_face_with_three_hearts:

1 Like

You’re welcome! :slightly_smiling_face:

@yusufcihan, How are you.
This problem is not solved. Its apperaing again. :pensive:

Can you show your blocks?

all blocks??

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.