Build failed — Application icon and Firebase config file error

Have you tried to reload creator.kodular.io ?

Click here and show result


image

1 Like

Yes. But nothing change

Thank you very much frends we fix the problem. Thank you very much

2 Likes

please share your solution
thank you
Taifun

2 Likes

I had the same problem and did this to fix it.

-Make sure the google-services.json is in the assets folder, and DON’T change the name of the file. Also make sure it doesn’t have a number, like google-services(1).json.

-The package name of your app, and the package name you provide to firebase to download “google-services.json” MUST be the same.

-I migrated my app from appybuilder to kodular, so you must export your keystore from the previous platform, and overwrite the keystore to the new kodular project (you can find the option in the top right corner in “Settings”).

-Then, in the “Advance” setting in the Screen1 design settings, I put the package name (Example of my migrated package name: com.appybuilder.user.projectname).

Hope this can save someone the troubles.

9 Likes

PROBLEMI NASIL ÇÖZDUNUZ PAYLASIRMISINIZ

@Yavuzhan_Yetgin Welcome to the forum. First of all please do not use Caps cause to me it looks like you are shouting and second see above reply from @mayoiha . I believe the problem was caused by google_services.json

1 Like

hello im glad to join your community .))
i just forget to turn off caps lock so im not shouting .DD
im still trying to fix this problem. thank you for your support.

1 Like

Here is my asset folder


and still this error shows
Capture
can anyone help me with this!!!

Did you read post 11

1 Like

Sorry I didn’t read the whole thing
I forgot to give it a pakage name

uchat.aia (364.7 KB)
Above is my project aia. Please check what is the problem. I am also getting same problem with apk generation.

@samiur9934 just tested your aia and apk created with no problem. Maybe problem was caused by a server issue at that time so just retry

Ok, thank you for help

Thanks Mayoiha. It worked for me. Now I am looking how to avoid the EACCES issue, but that is another thing.

please help me same promblem

Did you read post 11

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.