Camera component not working

Try mine CamTest2.aia (1.8 KB)

Yes, my blocks are the same, there is nothing special to it, yet it doesn’t work!

What does not work? Post your aia.

Did you try

Build the APK and try …

Did you create a new project? And add only these blocks:

Starting a new project the example works.
Modifying blocks in an old project seems not working.

I think it has something to do with the package name.
yes i created a new project, inserted the blocks and assigned a package name, which led to the error.
now i have left the blocks for the same project and deleted the package name now it works as expected.

And the package name is???

Nevermind, just tested and it’s not working…

@Kodular package name causes this

com.trendmedia.cameraTest

My package name is App.Receitas and it is not working.

Definitely the problem is package name.
I have run an example without package name and it worked.
I ran the same app with package name and it did not work.

I need to use package name because I am using Firebase Storage and Firebase Realtime database.

Yes, my problem too got solved after i removed the package name, and let the kodular decide it. It worked!!

Try to change this in the Manifest:

io.kodular to e.g. com (in my example)
in this line
<provider android:authorities="io.kodular.bodymindpower.camera.provider"

1 Like

Works on a Galaxy A3, Android 8.

I do not know where we could find this manifest file.

Try using APK Easy tool, decompile apk, edit manifest file and compile it again

1 Like

Works for me creating a new project and testing on android 9.

1 Like

What happens if you change the package name

I made this test and crach the app with the same error.

I created other app with a package name and the app broken. Maybe the problem was the package name be setting wrong in some native config file on build process.