Can't Allow Write System Settings

Hi friends,

i got confused with this permission write settings, why i can’t allow it. even i do with “manually”.
i am newbie here just start from scratch.

anyone have idea ?

and oh yea, i already search for this problem.

i already implemented this method, but still same as before.
even i installed that aia BeeriaApps shared, and still as before.

Please help me,

explain about your app in deatil

Do you need to allow it?
I mean which components do you use?

the issue is,

when i want update picture / name with firebase auth, it needs permission.
and i setting for initialize screen to ask permission.
but when it come to app settings, its not allowed me to enable it.

did i miss something ?

do not open setting for permission from your app

your error may be because android do not allow to provide permission if permissions are opened directly

i didn’t set before it needs permission.
and when i set permission, it still not allowed me to enable it.

share blocks

no, i think the problem is not from the block.

because i already do from topics i search and followed the instruction there.
even i installed that AIA provided in that topics.

heres the AIA, in that topics provides

writepermissionsolution.aia (1.9 KB)

and the aps still like mine before, not allowed me to enable it.

remove all blocks which are set to take permission, your app will automatically ask permission of component when they are required you do not need to set it up like that, tell me if it didn’t work

The issue is from my phone it self, but i didn’t sure which problem that caused can’t allowed read data / write data.

because i installed in lower android version in emulator, its run normally

soon i will updated again

As @Mika already suggested you don’t have a component that needs write settings and hence can’t change the slider on permission write settings…

Try this one

Scan the QR code on your phone to install the app.
Link valid for two hours


so i take it, its a bug ?

i already created apps before, and got no problem for reading permission or writing permission with anything component before.

but just now, i dont know what i missed that caused this issue, and as i see your reply, i take it as a bug.


I don’t think so, btw did you try the app above.


System write settings permissions is not the same like write external storage permission…

And btw the system write setting permission can not be granted through a block.

The user can do it only manuel.

And you have not show us anything what you want or what you have tried…

1 Like

I already sent the screen shot of apps it self, did you see grey color on slider?

See first post

Here i sent more of screenshot


for now, i already got conclusion for this issue with extension from Taifun, with file extension.
this extension

Thank you @Taifun
and also all people in this post thank you
@Mika @Boban @Deepanshu_Arya

Then you were after this

and not this, as you wrote about in your first thread/title


1 Like

I don’t know what difference between that you mentioned.

What i know is, permission to write or read is all the same

I am sorry if it got you all confused.
I have much to learn from you guys.

And as i said before, thank you very much
may Allah SWT bless you all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.