Can't connect to MIT App Inverntor 2 Companion


I just started to use Kodular Code Creator.
I imported my app that I created on AppyBuilder Online.
It is loaded successfully.
But, when I start Test / Companion, enter manually the code, and hit the ‘connect with code’ button, nothing happen.
Or, if I try the ‘scan QR code’ button, my QR Scanner starts, read the QR code, then disappeares from phone screen booth the QR scanner and the Companion, and nothing happen.

How can I solve this problem?

Best, Pali

Welcome to the Community!
Please make sure that you are using the Kodular Companion. You can download it from the Google Play Store

1 Like

OK, thanks!

1 Like

I just downloaded the Kodular Companion.
I can connect with it to my Kodular project to test it, but only when I enter the QR code manually.
The ‘Scan QR Code’ way still not works. Why?

it may be any temporary issue, try other project also may this works

I just created a new project for this purpose, to try out the ‘Scan QR Code’ way.
The project has only one button.
The Test process is unsuccessfull with ‘Scan QR Code’ way.
After my QR Code Scanner read the code, it disappeares from my phone screen, and the Kodular Companion also can’t be seen on the screen.

your phone specifications?

This is a Samsung Galaxy S4 Mini ( GT-I9195 ), with LineageOS - Android version 9.

By default the handset came for OS Android JB 4.2.2 which is very old and so is its hardware:

  • CPU Type Dual Core Application Processor
  • CPU Speed 1.7GHz

since you are using it with a third party OS which is based on Android 9 its quite common to face those issues and you may also lead to Companion failure when you live test a bit heavy apps due to those reasons

I understand.

So if I use this phone with it’s OS Android JB 4.2.2 then would the same error occur there too?

Kodular companion requires Android Version 5.0 or higher

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.