Companion not connecting after update, stuck at Establishing Secure Connection

Companion not connecting after recent update
its stuck at 20% Establishing connection every time.

Anyone else having this issue?



its working fine for me.
try by re-installing it may be it will work

It is not working on my chromebook or my phone. tried re-installing the companion app. Was working fine before the latest updated today.

I tried to login to creator from my phone and used the companion from there itself. It seem to be working.

Looks like the chromeOS Version 89.0.4389.16 (was updated today) broke the link between companion and creator in some way.

The same thing happens to me, well it loads me but it does not load the images or some components, even with blank projects, something must be wrong in companion

but will not load image as well as not get file as the dir for the asset in companion is changed after udpate

1 Like

and how can i solve it? I appreciate the help

which extension are you using for loading image

it’s direct from the assets

Can you right click and select Inspect then go to the Console tab and show that?

of course this comes out

1 Like

i hope it will work fine when apk is build

1 Like

this is the solution thanks to @Mohamed_Tamer

Are you using the beta version if the add-on? As far as I know it uses the new androidx support library, however the creator is still using the old support library, which could cause NoClassDefFound errors, as the classes in the old support library are not compiled with the partner …
PS: that could! This is why a blank project doesn’t work, as the same would happen with the display component … maybe you could try using the production version instead?

1 Like

A NoClassDefFound error is thrown when the block is run, and the application can’t even start because of the companion. I’ve used extensions with AndroidX with the Kodular companion and have had no errors, except that they just won’t work.


I am not getting errors though. screenshot attached.

I am using chromeOS (Beta version).


1 Like

Still having this issue, now there is a java error popping up which I didnot notice earlier

Not sure how to resolve this issue.

Appreciate your help


Companion Error… on 2 Different cell phones…

Waste to much time on a white screen an then with the code does nothing… not connects tested on two phones …

Working fine for me.

A post was merged into an existing topic: Kodular hangs at “20 Establishing Secure Connection”