Companion not working in firefox

kodular companion keeps disconnected in firefox but in chrome its working well . i have tried all methods availaible on community but no one working

Have you tried Updating Firefox? Im using Firefox and it works perfectly in Companion

1 Like

i updated but not connecting

For me works fine, no issues

1 Like

mine is continuosly dis connecting after 20%

showing this error in console
WebRTC: ICE failed, add a STUN server and see about:webrtc for more details

Does this happen on all projects or in one particular ?

all projects

Try this, open a new tab in firefox, type in address about:config In search preference name type ice.proxy_only See if is set to true. If so set it to false

not working

it was already false

Change also behind proxy to false and see if it works

i tried still it is disconnecting after 20 %

WebRTC: ICE failed, add a STUN server and see about:webrtc for more details

this is coming in console

Unfortunately Iā€™m out of ideas.


Your Connection is Slow or DNS Problems, it happens to me a few hours ago, set your DNS and

where to set it

1 Like

Try to clear cache and reinstall your Firefox

If works plz marks as solution

Navigate to Control Panel > Network and Internet > Network and Sharing Center > Change Adapter Settings > Right Click Ethernet (If you are connected with LAN Cable) or WiFi (If you are using a Wireless Connection) > Click Properties > Click Internet Protocol Version 4 (TCP/IPv4) > Click Properties and Follow the Settings Below :point_down: :point_down:


Hope it Helps :>

If this one doesnt work, try to Turn Off your Proxy & VPN from your Settings

i have reinstalled firefox

i have cleared cache

i have turned off proxy

i have turned off vpn

i have changed dns

i have done every single about:config setting to false as mentioneed in kodular comunity to make companion connect

but still companion is disconnecting after 20 %

these are webrtc data

I always testing firefox. Working good. No issue so for

Is your project too big?

no it is small