Deleted Button Still showing in the APK

I have deleted a button from My side menu, save my Project and then baked my APK when I test my APK the button I delete still shows up.
I have made sure to delete every block used for that button and it is, and does not show up in the Companion but when I bake the APK the deleted button still shows up.
I have tried to save, save as and export but the button is still there.

Anyone have any idea how I can solve this please as it is very weird.

1 Like

Refresh the site…
Then delete the button…
Make sure check the internet connection…

1 Like

Thank you I have tried all that many times the button does not show up in the Companion it has been deleted
But when I create the APK and test the APK the button that has been deleted is still showing up in the APK

And my internet connection is perfect

Would you mind sharing the AIA?

1 Like

deliver.aia (561.8 KB)

I removed the Donation Button from the Side Menu

Google said I was not allowed to use it as we are not registered as a charity or organization yet so I have to remove it.

I have done so but when I create the APK and test the APK making sure to remove any older versions of the app the Donate button still shows up in the app.

It is very weird, I have tested it 7 times now

Thank you

Try this: deliver2.apk (7.4 MB)

1 Like

Hello @bodymindpower. thank you for the .apk you have provided it worked, but mine still does not.
So I shut down the Mac at around 4 am and slept for a few hours when I turned the Mac on today I tried Your APK and then I when back to my Kodular account and tried to bake my APK from my account again and the Button although clearly removed is still showing in my APK.

Please can you tell me how you were able to get it to work
I have tried deleting cookies and cache but that did not work either.
Very weird that I am unable to save an edit of a deleted button, The button does not show up when I test it in the Companion so I am confused why it shows up still in the APK I bake.

Thank you

I am truly astounded I have deleted all cookies and cache on Chrome and Opera
I tried to bake the APK on both Browsers making sure that the buttons are clearly deleted
and on Both browsers with cookies and cache cleared for all time, the APK came out with the Donation Button still showing.

I make sure to delete the app from my mobile at each test so it is like a new install every time I try and have to accept the permissions.

I would love to know how to solve this as I have a number of apps I want to edit and if the edits are not going to save when I bake the APK I am going to have a lot of frustration.

Any help in solving this problem would be very much appreciated.
Thank you

You are sure you don’t have two apps on your phone…

1 Like

I had the same guess as Boban.


Positive I make SURE that I do not have the old app on my Phone and I have to accept the Permissions each time as if it was a fresh Install
Thank you

P.s I have just tried Again but I get the same result the Button is still there.
Extra certain that I do not have 2 apps in my mobile and yet still the donation button shows up
I have tried with Both Opera and Chrome, both with All Cookies and cache deleted
I am dumbfounded

Why not try to add some extra buttons and see what happens…

Btw, I checked your aia file and there is no reference to Donation Button

The second possibility is that you always install the same (old) APK.
So delete all files / APKs from the download folder (PC and Android device) and try again to build the APK. Copy this APK from the download folder (PC) to the download folder of your device and install it.

1 Like

Make sure you are installing latest downloaded apk

@Boban yes I have Removed the Button so I am gobsmacked that it is still showing up

@bodymindpower I create a new APK from a Saved As file every time I try there is no possibility of it being an Old APK
I have made sure to delete the APK from My Mac Desktop every single time time I have downloaded an New APK
There is literally nothing I have not tried and Still the DSonation button is showin up in Any NEW APK I create from either Chrome or Opera no matter how many times I delete the cookies and cache of the browsers.

@sonumohammad333. Thank you I am extra certain that I am downloading a new APK each time as this is My workflow.

Delete all cookies and cache, Log in to Kodular, Check the Project I want to export and make sure everything Is in order, Then Make sure My Mac is clear of any older APK then check my mobile and remove and Old APK , then export/bake download, I use the SendAnywhere app to pass it from my Mobile from my Mac making sure that all previous downloads via Sendaywhere have been deleted from the Sendanywhere app so the ONLY app that shows up is the App I have just downloaded from Kodular.
I move it to my mobile Install it Accept permissions check Menu and the Donation button is still there.

I will send a video If it helps to show you what is going on I am truly astounded as I have tried Everything.

@Boban I tried adding a new button called test it did not show up but the Donation button did.

Delete project and upload you aia file to Kodular

Hello @sonumohammad333

Thank you I have already tried that

Log out from your kodular account and upload the aia in another account and see what happens.

1 Like

You mean another platform or another gmail address?

Thank you

Try this aia: deliver_2.aia (561.8 KB)
build the APK and install it.

1 Like