Download an APK to App-Specific Directory (ASD) and install it without permissions

… and here (post #4)

1 Like

Read it this way:
path (of) APK

1 Like

Thank you for this amazing extension .

1 Like

I did this and it worked, thank you soo much.

1 Like

Fine, but you can avoid an additional extension (TaifunFile):

1 Like

Note: The extension is now updated to AndroidX libs.

First, I want to congratulate you on your excellent work. I used your solution to create a private (non-commercial) app for my family and your part worked perfectly. But I need your help and the community to finish this my app, because it’s still not 100% complete and as I need it for my family’s use. As we all have cars with Android Auto, I’m putting in this app I’m creating an installer of useful apps for use on Android Auto, like Screen2Auto, Fermata Auto, and more. The problem is that this type of app needs some authentication (this I think) to be installed by another app, such as the AAStore and AAAD apps. When I try to install some of these apps from the app I was creating with your install solution, the app doesn’t work properly on Android Auto. Could you and the community help me with this? Just tell me how I get it and I’ll have all the trouble to do, no problem. I look forward to your help and the community please!!!

Hi Anke,

after i Installed your APKInstall v5 and only drop the extension into Screen1, im not able to Compile the APK. I get the following error Message, maybe u can see what the Problem is, ty.

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.287 seconds
________Compiling source files
(compiling io/kodular/abm_com_app/S30_TK/Dokumente.yail to io.kodular.abm_com_app.S30_TK.Dokumente)
(compiling io/kodular/abm_com_app/S30_TK/EmailTBS.yail to io.kodular.abm_com_app.S30_TK.EmailTBS)
(compiling io/kodular/abm_com_app/S30_TK/Einstellungen.yail to io.kodular.abm_com_app.S30_TK.Einstellungen)
(compiling io/kodular/abm_com_app/S30_TK/Kontakte.yail to io.kodular.abm_com_app.S30_TK.Kontakte)
(compiling io/kodular/abm_com_app/S30_TK/Ticketsystem.yail to io.kodular.abm_com_app.S30_TK.Ticketsystem)
(compiling io/kodular/abm_com_app/S30_TK/Screen1.yail to io.kodular.abm_com_app.S30_TK.Screen1)
(compiling io/kodular/abm_com_app/S30_TK/Downloads.yail to io.kodular.abm_com_app.S30_TK.Downloads)
(compiling io/kodular/abm_com_app/S30_TK/Technik.yail to io.kodular.abm_com_app.S30_TK.Technik)
(compiling io/kodular/abm_com_app/S30_TK/Startseite.yail to io.kodular.abm_com_app.S30_TK.Startseite)
(compiling /tmp/runtime6903766324395304431.scm to
Kawa compile time: 7.036 seconds
________Invoking DX
DX time: 21.771 seconds
________Invoking ApkBuilder Failed to add /tmp/1628499676819_0.8598770255207662-0/youngandroidproject/…/build/tmp/classes3.dex
YAIL compiler - ApkBuilder failed.

I checked my extension again. I built an test APK. No issues …
App work as expected. There might be problem with something else …

I got the Error too.

I checked it again on Android 11: no problems at all.
Create a test app with only my extension and test … it will work …

1 Like

Yeah, I think it conflicts with a other Component or Extension.

Above error is mainly caused when two extension of a project have same library. And this extension does not contain any library as I can guess by its size. So I think there are other extension of your project are generating this error.

1 Like

Seems like a pretty small Library because export has worked before import.

Post the aia (before importing my extension) or send it to me via PM.

@Ded_Sec_00 I checked your aia. There seems to be a conflict with the Draco extension. Remove it and the APK will be created.

Is it possible to use it together? I need both extensions :sweat_smile:

Hi Anke.
I’ve used your extension for a while now, but a few days ago I bought Alarm Manager

Link to extension here

App Inventor Extensions: Alarm Manager | Pura Vida Apps

After making a test project and got it working I was importing it to my main project. But there I get error when compiling. After some testing it seems like your InstallAPK extension and Alarm manager extension are having trouble together, any idea if this is something I can fix, or is it same problem as the others, with library and cannot be fixed?

The error is same as Ded_Sec_00 - so I guess there’s nothing to do but remove one of those aix?

I checked it:

1 Like

Ok, I’ve tested on main app and a test app myself, and don’t get it to compile :thinking:

I just made another “Update app” as a workaround. On main app initialize it checks version, if new version it lets user start the other app and download, install and go back to main app. The only downside are that the user has to install 2 apps for this to work.

But I will have another try and see if it was just that day something was wrong or if it continues with error when compiling :wink:

Btw, ty for the feedback :smiley: