Download any file with webviewer


i’m trying to set a block that let me download any kind of file like normal browsers on the playstore.
Unfortunately i got this error:

My download block is this:

How can i solve this?


If this give same error, post your download url

i really apprectiate your answer, thank you. However the error is changed now in this:

My new block (following your advice):

And this is the link that i wanted to download:

Thank you in advance!

Try this aia :point_down:

CWV.aia (68.8 KB)

May not work in Android 11 until this bug fix

Also See


Use Download Helper from CustomWebView :point_down:

Tried this from:

CustomWebView : An extended form of Web Viewer - #1302 by Anu10

My block:

and tried this from:

CustomWebView : An extended form of Web Viewer - #1303 by vknow360

with this block:

but in every case i have this error:

My testing phone is a Doogee S88Pro with Android 10
EDIT: On another phone, instead of that window, nothing happen. Simply the download does not start without any error or warning.

Did you tried compiling my aia ?

CWV.apk (5.3 MB)

For me download starts without any error.

Yes, i tried but nothing.
It give me the same error:

Maybe i found the solution, but now my app does not compile anymore. Give it to me this kind of error:

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/..
________Creating listview xml in res/layout-v21/..
________Creating xml in res/drawable/..
________Creating splash png in res/drawable/..
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.082 seconds
________Compiling source files
(compiling io/kodular/luca1334/Simple_Browser/Screen1.yail to io.kodular.luca4.asdasdasd.Screen1)
(compiling /tmp/runtime2211785962717768109.scm to
Kawa compile time: 1.195 seconds
________Invoking DX
DX time: 2.672 seconds
________Invoking ApkBuilder Failed to add /tmp/1658936817495_0.37922318883339956-0/youngandroidproject/../build/tmp/classes2.dex
YAIL compiler - ApkBuilder failed.

This is happened when i’ve installed this two extension togheter:

But in another project they work well togheter. How can i solve this?

Chk project in project …