ERROR 903 The permission WRITE_EXTERNAL_STORAGE has been denied

Hi! I have the same problem. Please, what I can to do to solved it? Or, where I can to find the solution??

Which problem? Show your relevant blocks.

The error is : ERROR 903 The permission WRITE_EXTERNAL_STORAGE has been denied. Please enable it in the Settings app.
This error only appear in other devices. In my own device the app works perfectly (installing .apk)
I don’t know which blocks to show you.

When open app, the app ask for permission automatically to access photos and files from device.

We definitely need more details about your app.

  • What is stored where?
  • Which Android version does your device have?
  • And on which Android versions does the error message appear?

ok, thank you for your attention.
when initialize app, I do this:

and this is what I save in the file:

The app support from Android 6. The Android version of my device is 10. The other devices has various version, but no one too old version.

Hi. There is another thing what happend in my app. I’m talking installing the same apk in my device and in other devices.
Plese, watch videos.
1.- Must to do. Installing the apk, in my device. When the user click in a item, select quantity and press green buttom, must to add to the shopping cart. If click in a item already in shopping cart, automatically you get the unit in the shopping cart of this item. Top of the screen, the user can to know how many item are in the shopping cart. Pressing this green shopping cart goes to see the shopping cart.

2.- Video Error: When press the green button to add item to the shopping cart, it don’t doing. To do this, I’m using List. Simple List. But doesn’t work, does not add to the list nothing. I don’t know why. I guess it’s because of the permissions.

It is my first Project. But these incomprehensible mistakes do not let me finish and discourage me greatly. I love Kodular, but I dare not continue doing things if I can’t make them reliable.

Thanx for your time.

The key to a successful project is to do it step by step… add new functionality, test immediately, fix the bugs and after that continue adding more functionality etc
It looks like you forgot testing immediately… and now you created a monster with loads of bugs…

Start testing now and use Do it to debug your blocks. .


1 Like

Thanks, I was testing in my device continuously. The app always was working in my device. And now works fine, but only in my device (installing apk) This is what I don’t know how to fix and what, because always works for me.

of course, thanks for your advice.

The File component saves the text file in PrivateDir (internal storage) when using a path without a slash at the front, and incorrectly requests storage permissions on all Android versions.

It currently makes no sense to work with the bugged File component.
Try my MFile extension.

Here the File component tries to read from the PrivateDir. Where does this text file come from. Where was it saved?

1 Like

You should use “EFile”, the original extension that still works today! It was made to fix a problem, not make one :)

1 Like


I thought it was saved in the folder of the private app. But no, I don’t know where he kept it. Now with the slash, it does in the app folder. Thank you.

I solved the error 908 on screen with these blocks:

Thanx to @bodymindpower .

Now I’m trying that the app run same in all devices.

I understand. You are right. So I will. But how do I indicate the private directory?


Hi friends! this is what I have do. It near works but, for some reason, when you press OK, the choose dialog run 3 times :man_shrugging:, and infinite if you press SALIR (OUT). It Ask and Ask a lot of times until you press SALIR.

  1. No, it doesn’t need to be added in the Manifest, because android:requestLegacyExternalStorage="true" is declared in the Manifest by default with Kodular, same with AI2.
  1. No, on Android 10 you can access all external storage directories, (exactly) because android:requestLegacyExternalStorage="true" is declared in the Manifest.
  1. No, storage permissions are no longer required for Shared folders on Android 11+ only. On Android < 11, these must be requested in order to gain access to them.
1 Like