Error occuring while exporting, Firebase config file error

Please help me. An error is occuring while exporting my app


Maybe this can help you

I am Also Facing This Error

I myself think that this error might be there because I used firebase authentication without google.json file. I need to check it nut to get the google.json file from firebase I need the keystore but in this new version I am unable to get the keystore. Please help me out with getting the keystore.

It is in the same place as it was before. Account → Preferences → General

Unable to get keystore here, please help

If you never have build an apk there is no keystore available.

Thanks I will certainly try and if I face any problem I think I am free to ask for help.

what about clicking the View Log button to find out, why and where the build failed…


Nice Idea, let me try

Sorry to tell that even after getting google.json file, I am unable to build the apk.

I have tried taping on view log. Here is what I got-
Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file error.
This was the text I got in another tab.
Please help me.

I see you don’t have much reading time on the community. Your problem was asked many times before.
Search results for 'Firebase config file error' - Kodular Community.

Sorry, to say that none of them solved my issue
Is there any problem because I used cloud db in the project?
I added 30 cloud dbs from mit app inventor and exported the file from mit and then imported it in kodular so that I can get all the required components or my app which are available in kodular but not in app inventor.

That was quick. What have you tried to solve the error with the links i gave you? The Firebase component from App Inventor is experimental and different from the Kodular one.

I amn’t using app inventor firebase. I am using Kodular Firebase Authentication.

If you wish post or pm your aia to check it

Its a confidential app for business. Sorry, I can’t post it