Error on companion connection

Is been really impossible to work! Since a week I can not run my app tests on my celular! The connection drops within 5 seconds and give a reply: “Network Error! The Companionon has disconnected”
I am thinking to give up the use of Kodular and try another tool…if I have no solution for this!!!


Send image of your blocks.

Yes, I experienced similar connection drop and compiler error issues in the last few days…

my compiler doesn’t load more than 20%.I am also feeling like you. also face so many bug-like.server error etc.

1 Like

This is because server of kodular is down. It updated for new features in few days.

I assume you mean Companion. As a BetaKoder, you should know to search for the issue. It is known that the error is caused by changes to Chromium. Pavitra confirmed that it will be fixed in the future:

…and until then, use a non-Chromium browser such as Firefox to use the Companion.

There is no such news.

1 Like

You can check kodular status on

We are still in the same situacion. Not beingable to test my app project makes the use of Kodular unfeasible.


I agree with you, this situation is really annoying

I was able to get past this by running on Mozilla instead of Chrome

i was running on chrome

I really appreciate everyone’s participation! Now I got to work by connecting via USB! Even so, it gives the error information that I click on “cancel” (about twenty times) until the companion enters and does not fall. I believe it is an excellent opportunity for Kodular’s technical staff to solve these problems! If you need my help in any way, I am at your entire disposal!!! My best regards!!!

i also have same problem when i was using chrome but
now i am using firefox it was working few days but there also it is same problem it just not do single %

Companian problem solve 1100% in kodular in tamil step by step

Edit by Mod: If promoting YouTube Videos, then make sure they are in English.


Wooo My Problem has been Solved. :grinning:

I hope Mods can close this thread as there is no problem with companion connection.
If still problem is there, just ignore this post.

I cannot get the companion to connect. Was working fine up until a few days ago. Now connect by QR code does nothing. Tried reinstalling companion, but no change. I can see no reason for this. Anyone have any ideas? Using Firefox, but doe snot work with Chrome or Edge either.

On this post you can find an answer: Guys I'm having problem with companion is not working at all! - #66 by Lily