Error trying to compile

I don’t know if anyone else is getting this, I uploaded my google-services.json file and I get this:

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating styles xml v21
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found
________________Firebase config file error

I might know why, I entered the wrong package name on Firebase…

Outcome: Still the same error, stops at 24%.

You need to have the same packagename in firebase as in the creator. Also you need the latest version of google-services.json to get a working compile.

1 Like

I changed it and I do, but it’s still not compiling.

Already do.

Is the file called google-services.json?

For some reason it’s working now :thinking: I created the same app in Firebase 3 times trying to add it, and on the last try it worked… I’m still wondering what happened.

I just tested, and it worked properly for me
I had that error, but it worked after fixing the package name and saving the project

1 Like

First time, or 3 times?

First time failed because of Package Name
I changed to the right one, Saved project and it worked

1 Like