[F/OS] - Dynamic Components Extension (for every component) 2.2.2

I think the main reason for @themaayur is he wants to get the ID after he created the component. But I don’t know why he needs that too.

Then I can change the socket type of Create block, so Create block can return the value, BUT it will be an important decision, as people will need to change the blocks to new ones.

Maybe add a new block just for that (I don’t anything about aix/java, so don’t blame at me :sweat_smile:)

But adding the same block twice may confuse the users :thinking: As I said it will be an important decision I think, so I should not take any action without a lot of feedback :sweat_smile:

1 Like

Maybe name the new block as CreateWithReturnID or sth like that

There is a lot to do with it. Like animate it, or register something on components created ar more that depends on your usage.

So what’s do you think ?

But why you need to get the ID? Didn’t you already have that?

Or alternatively, use this block to get the last ID of component that you created previously.

component_method (1)

1 Like

I have a horizontal arrangement in which a textbox is there, I want to create a dynamic image but which side will the image create, to the right of the textbox or to the left of the textbox?

1 Like

it will be created to the right of textbox

And if I want it to be created on the left side

Take any arrangement left to textbox and create in it

But that’s not what i want to do, basically i want to reduce components. so if I use another arrangement, Im increasing components

my image is not showing after create dynamic,no error…always check my block,first can showing normal…until day by day,i never change the block,is not showing again…any have same problem with me?

Maybe you add something causing something wrong. Show your block, and you have to confirm that the image is either accessible with URL or in the asset.

This is my blocks … please check what’s wrong.

Can you check if the image list have anything in it?

Yes I Checked But It’s Nothing Error

R u using latest version of extension?
Have u tried image from assets?
What is the total length of your data list…

Yes I Am Using Latest Version.

Yes I Have Tried Image From Asset But It’s Working.

When I Try To Fetching Image Or Something else From My Server it’s Not Working. Please Help Me