File is not saved, permissions are not recognized

Unfortunately, I haven’t had the time to work on my project for a long time because of my work. Luckily that has now changed again. Thank you for your help so far. I would like to save a file in my mobile phone’s download folder. So not only in the private memory of the app. But that doesn’t seem to be working

You might want to provide a screenshot of your relevant blocks


The code is still the same as on my last sent screenshot.

If you want to store in folder /Download, then you should use this filename


1 Like

I was using File Scope Legacy and getting the 908 Permissions error as always. But it was queried beforehand and I confirmed it.

Try the MFile extension


1 Like

I tried.

But here the file is only saved in the App folder. Not in a normal public folder. I’ve tried a lot with the extension, unfortunately nothing has led to success.

Are there any other solutions? Haven’t you had any problems with it yet?

show us the Do it result


Here is the result:

as you can see yourself, you are storing the file in ASD…
what about using the path /Download/Test.txt to store it in shared storage /Download?

That’s right. So far, only saving in the app folder is possible. But as you said, I would like to save the data in the download folder. Previously this was not possible due to the errors mentioned above. How can I save the data in the download folder. Unfortunately nothing has worked for me so far.

previously you used the file component
it does not look like you tried the suggestion from my last post

also you should learn how to use Do it to debug your blocks, see also tip 4 here App Inventor: How to Learn | Pura Vida Apps
see also Live Development, Testing, and Debugging Tools

I implemented your recommendation and installed and used the extension. The same problems arise here as well.

as far as I understand this thread, your goal is

So why do you continue storing the file in ASD then?

What you are saying does not make much sense, does it?

If Do it does not work for you, how are you able to provide a Do it result then?


Sorry, maybe it’s all mixed up by now. My goal is to save a file as described in the download folder. Unfortunately, every attempt has failed so far. The only thing that works is that a file can be saved in the ASD. Everything else hasn’t worked so far. I’ve tried different paths. There is always an authorization error. In the extension I tried every building block. Each building block is stored in the ASD and not outside. But I want to go there. Do it somehow didn’t work at the beginning, hence the sentence. I have now adjusted my text because it then worked as can be seen in the picture.

Ok, start again from here

And in case there already is a file myTest.txt in your Download folder, delete it before starting to test

In case it still does not work for you, then provide a screenshot of your relevant blocks and NOT a screenshot of saving a file in ASD


Here are the blocks:

Bild 1

Nothing is saved and although all permissions have been granted, the application starts with error 908 (as mentioned above). A do it result was not given for either the extension’s block (used in the screenshot) or the normal file block (without extension).

The blocks look fine and should work without asking for permission
I probably can do some tests tomorrow…


I actually think so too. But don’t get it to work. Thank you, I would be very happy.