Firebase Authentication error

@GaryH It is still causing the same error. It is running into Login_Failed() When I’m installing from Playstore. My blocks are given above… Any help would be appreciated :slight_smile:

Have you added the SHA-1 certificate to the firebase?

  • Go to your Google Play console > App Signing certificate > copy it
  • Go to your firebase account > project settings > (Here you should already add your app and upload google-services.joson to Kodular) > project info and add fingerprint > paste the signing certificate from google play console.

Besides, I noticed that you didn’t set up the clock component the right way.
The porose for the clock here is when you have private rules, the clock waits 1 second after the token gets set. Then, you set the project bucket.

Capture
I would suggest to add this block and leave empty to ignore the error on start (permission denied).

1 Like

I can see an MD5, SHA1 and SHA-256 certificate under app signing certificate.

  1. Do I need to add only the SHA-1 certificate to firebase or do I need to add SHA-256 certificate also?
  2. Also I want to mention that, previously I’ve already added the SHA-1 certificate from Kodular Settings to the Firebase. Do I need to do anything with that?
  3. After adding the SHA-1 certificate of PlayStore to Firebase do I need to regenerate the google-services.json file and update in Kodular or the one I’m already having their would work fine?
  4. After all the above tasks is it necessary to recompile an APK and publish to Playstore or only adding the fingerprint to Firebase would directly work? (The lamest question among all) :stuck_out_tongue:

Thanks @Hassan_Alzaki for providing the details and it would be great if you can answer my above queries too :slight_smile:

In your case, you would need only SHA-1
SHA-1 : Used to create OAuth 2 client and API key for your app
SHA-256 : Used for configuring Firebase Dynamic links

As far as I know, you may add both, the one from Kodular and Firebase.

I would prefer to regenerate the file and upload the new apk because the google-services.json file may get updated.

1 Like

I added the SHA-256 too before you replied :sweat_smile:

Did so and published on PlayStore waiting for a successful rollout. I’ll let you know if this works! :smiley:

SOLUTION! I can’t mark solution since I didn’t started this feed. LOL
Thank you so much @Hassan_Alzaki :smiley:

1 Like

You are very welcome :smile:

1 Like