GetTags - Didn't return a list but something else

Hello Community, I was creating an app where I use a TinyDB.
My problem is that the GetTags block of TinyDB returns something else instead of a list.

NOTE: Because the Kodular Companion is not working, I cant Do-It my Blocks.

This is the result -
Expected Result

[test1, test2, test3]

But Returned

(test1 test2 test3)

I also tried to use like this -
image
But the same result.

Can anyone help me solving this issue?
Thank you…

If not mistaken you have to enable Show Lists As Json in Screen’s 1 properties in order to see the expected result. Can not test it either due to companion’s problem

image

Thank you @dora_paz, I have checked the ShowListAsJSON checkbox and it is returning correctly.
But when I show there tags in a spinner it shows bracket like this (test).
Blocks-
blocks (31)
These are the tags in the TinyDB -

["testBatch"]

Result
First Item - --Select A Batch--
Second Item - (testBatch)

Set the .GetTags list to a local variable, then insert “Select A Batch” as new item at index 1, then set your local variable list to the listview. Should return:

1st item: Select A Batch
2nd item: testBatch

Like so:
image

1 Like

Thank you @TimAi2 and @dora_paz for your help :grinning:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.