I can't load my .mp4 files for my video game

Hi everyone! I have decided to enter the world of video games with Kodular, the truth is that it took me a lot to find a way to perform various actions but in the end I was able to do it.

But I have a problem that so far I have not been able to solve and I have already tried all the methods available in the community. I cannot load several of my .mp4 files, nor can I play them in the companion at the time of development. If you could help me with that I would really appreciate it. :slight_smile:

I am eager to publish it in the Play Store and that you can give me your opinions.

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


1 Like

Nice to greet you! The problem is precisely that I try to upload the files to the assets but when loading kodular again they disappear, as if it did not let me upload .mp4 files

did you try with only one file? how large are the files?

I uploaded a single 19MB video and when updating kodular it disappeared. Is there a way to download the files and store them in the cache or in an invisible place on the device? There are about 5 videos and 10 audios that weigh approximately 100 mb in total.


1 Like

Tried this method and was unfortunately unsuccessful, I have an iMac and can’t complete step 5 of the AAB guide.

You can use any Windows OS in Virtualbox on iMac

From my guide:

Sign the AAB (→ Java JDK 8):

jarsigner -verbose -sigalg SHA256withRSA -digestalg SHA-256 -keystore
android.keystore appName.aab androidkey -signedjar appName_signed.aab

Did you install JDK 8?

1 Like

I already installed it, how do I access it? Do I have to enter the terminal? Sorry I’m lost :slight_smile:

I managed to load the files, but I can’t play them. The “Exists” block gives me “true” but does not play the video. I am doing something wrong?

The VideoPlayer cannot play videos from the assets (APK).
This bug is still not fixed. I really don’t know how many times I’ve pointed this out. :upside_down_face:
The first time in July 2019.

Btw, on Android < 10: @vknow360