Imported project files are not opening

I am trying to import an AIA file in Kodular but when I click on the project, it freezes on the loading screen. I thought there might be a problem in my AIA file so I tried to import another file, but the same problem repeats. I haven’t got any error message from Kodular so I have no idea what is wrong. There is nothing much in the AIA file and also there are no errors. This problem occurs only when I import a project in Kodular. However, this problem doesn’t persist while opening an existing project. How can I fix this? Or is this a bug?

1 Like

You tell nothing about your aia. How are we supposed to help you. Where is it from. Is it your own. Does is contain extensions. Does it have large assets, how big is it. Etc etc etc etc.

1 Like

You are right. There are no extensions used and there are only few components:

  1. ChatView
  2. Firebase Database
  3. Label
  4. Textbox

That’s it!

Here’s my AIA: TestChat.aia (7.0 KB)

I think this is happening because I deleted a project and didn’t wait till getting it deleted completely and imported an upgraded version of the same AIA file by mistake.

It is coming from AppyBuilder?

I see it is a damaged file. There are no screens and block files in your app. So like you yourself said it was damaged, maybe by your own actions but that i do not know.

No, this project was created on Kodular itself.

I don’t know what’s wrong. I had integrated a chat system with firebase by myself in this AIA file.

Not just this one, I tried to import an another project and it is still freezing on loading screen. But the existing projects are working perfectly and has no issues.

There is currently a known bug where some project files aren’t being included in the exported .aia file. It will be fixed in the next release.


It was happened with me also.

When i try to export a project or screen, it was exporting but when i import it no screens or blocks are seen.

When i unzipped the file and checked, there is no screen (scm) of block (bky) files.

I think there is a bug.

But when tried restarting browser and clearing cache, it works sometimes.

1 Like

Even i have faced the same problem

the same problem happened to me, he is not creating the src folder, the only thing I managed to solve was to save each screen in the .ais format, and extract the .aia and put all the files inside and compress in the .aia format again

1 Like

I also tried this…I restarted my computer and also cleared browser’s cache memory but still the same problem occurred. So as @Conor said there is a bug so let’s wait for the next release :slightly_smiling_face:

Same problem .
Any one know how much time bring for next release.

I also could’ve asked this question :joy:

Can i import my project in other app inverter platform

See here:

No. You can’t import your Kodular project in App Inventor if you’re using Kodular-only components (like the monetisation or dynamic components)


I don’t monetizo my applications because they are Christian

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.