Is Companion working Fine at this time?

I am trying to Live Test my app for like an hour and the companion app is not connecting. On kodular creator the website is stuck at QR code, after scanning the code nothing is happening.

I tried removing the beta version and installed the stable version.
using chrome to access kodular creator
internet speed is good - 27 Mbps (tested now)

3 Likes

It works fine for me

i dont know why it is not working for me, it used to work perfectly before. It is now stuck at QR Code, I tried different browsers still no luck

I am working now, testing is working normal. Try delete Companion and install again. Also you can reset connection on site, stop the Companion app and try again :wink:

Maybe wait a little and retry

The Companion sometimes goes down due to server issues, but is restarted automatically every hour (use UTC as reference). If you’re in CET, for example, the server restarts at every X:00, and if you’re in India, it restarts at every X:30

2 Likes

okay thanks I will retry after an hour.

I also found one more thing

  • Companion works fine on Chrome [but chrome sucks, too much laggy]
  • Companion also works fine on mozila. If disconnects in b/w and then try to connect again, an Error popup everytime “Companion connection error state = failed”. But if tried again like after 4-5 minutes, it will again work fine. [There is no such issues on chrome]

Edit: One more thing, If you are trying to use qr code [for test mode] OR using the right click options [in block section] and suddenly an error popups, then the option or qr code’s cancel button will not work, only error popup cancel button will work, but that error popup will be behind those options so nothing will work. Now we have to reload the page.

1 Like

it is sad to say but Kodular’s performance has gone really down, I dont know what is happening,

The project takes 3-5 minutes to load.
QR Code live testing is not working.
When the creator loads it lags a lot.
It has become unsable.

and yes another major problem which I have discussed a lot : The Images in the apk takes a while to load, none of these problems were present like 6 months ago, now everything has become unsable.

I tried all these things on three different Laptops, but results are same.
Is anybody else facing all this or it is just me ?

hello @Vishwas i am trying to connect to companion since last 4 days but i am not able to do so, I have tried leaving the beta program of companion app, cleared app data, installed stable version but still when I try to connect using companion app it scans the qr code, and then nothing happens, please help me resolve this.

for me too it happens few or more times, i too created a new topic but no reply

1 Like

for me companion works fine on chrome (but on chrome, builder lags like hell, so it is of no use)
On mozilla after every accidental disconnect, I can use companion after 3 pops ups. 1st and 2nd pop up says disconnect. and 3rd one says failed. And after that 3rd pop up everything is fine. (this will take around 4-5 minutes)

1 Like

Please rebuild companion from scratch.
So it will be bug free.

1 Like

is anbody from Kodular listening ? :thinking: this is becoming a problem to users

Can anybody please help ? It has been over a week @Peter @Diego

It shows this after scanning the code !

Capture