It seems FTP Component is not working

Please find the blocks Below. All I need to upload an image to my webserver.


When I tried yesterday with the same code, The file was uploading to the Root folder where the /public_html resides. But today it is not even uploading to the root folder also. Is there something wrong with my code?

Please help me regarding this issue.

Is your site an FTP site(meaning it starts with ftp://)

1 Like

Yes it has an option to send files through FTP. I can open my website through File Zilla also to copy edit etc…

See how I’m using it as well as what I wrote in that thread

1 Like

I have a question.

My ftp account on my server is programmed to connect to a specific folder / public_html / ftp /.

In appybuilder it only works with a final folder type / user and it worked perfectly. In kodular I can’t get a file to upload via FTP, like this / user.

I even tried / public_ html/ ftp / user and it doesn’t work either, I can download files without problem but I can’t upload.

Working_directory confuses me.
which path should i use?

does the directory /public_html/ftp/user exist?
what is the result in the Upload Error event?
what about providing a screenshot of your relevant blocks?


I think I have the solution, I confused some blocks, thanks taifun for the moment, my site is down, when it is restored I will do the tests.

I have followed this method and everything wotrks fine for me but I don’t know how I can get file path url afer file uploaded

Kindly I need more advanced help

Try your web url http:// or https://

Wow, @Boban thank you in advance for your suggestion I have managed to upload the file to my server and got the file pathUrl by using there blocks

Because from my end FTP Component is working fine!
:point_down:t2: :point_down:t2: :point_down:t2: :point_down:t2: :point_down:t2:

I would then like to ask @peter to split this post as a solution and make it as a guide for Kodular on How to use FTP component to uplaod file to a server and get filePath Url after uploaded