java.lang.ClassNotFoundException: kawa.standard.Scheme

Hi, i built my app and it all fine since last week, copy screen and modify as i needed, but now it shows error after i install it, it automatically closed right after i clicked the icon app and it show this error (not sure if this kinda adb logcat)

i’ve looked for the solution the whole day and there’s plenty with similar error, but other just shows the exact error (ex:…Unbound location null, etc). i can’t find any stange on my Screen1 and i dont find any error related to “ClassNotFoundException: Didn’t find class …” that satisfy what i’m facing
here is the only properties and block on screen1:


here is extension i use:

note: i’ve not left properties empty, same error using device POCO M3 and Redmi Pad SE (android 13), App Minimum SDK Level 21

thanks in advance

Check for the latest versions of the extensions that you use…
for example …

all updated with latest version and even deleted the CompareDates extension because i didn’t use it last week but still the same error.

i worry about package name and version, because this project was exported and imported and also i copy screen as i needed. it’s just add screen without modify any other properties.

i did changed the package name, version, app name before i posted this topic but got nothing

Has anybody ever faced the problem and managed to solve it?

Is this a large project?
Use and post the result screen


Yes it is, i also use unchive to kinda debug it. I cant show you now, i’m already home.

As far as i remember, it contains 12 screens, with approximately 20k blocks, 1Mb of assets, 4 extensions, 7 Mb of built apk, most used component: Label (± 900).

Earlier this day my app able to open by replace some “Label” with another component which in unchive tells i use a lot of it, but then i do some modify but still the error persist.

is using particular component to much can cause an error?

Forgot to mention, after modify i got another error which i didn’t found any discussion/topic similar to it:

java.lang.NoClassDefFoundError: Failed resolution of: Lkawa/standard/Scheme;
at io.kodular.bmatest5150.Prod.Screen1.$define(Screen1.yail:10288)
at android.os.Handler.dispatchMessage(
at android.os.Looper.loopOnce(
at android.os.Looper.loop(
at java.lang.reflect.Method.invoke(Native Method)
Caused by: java.lang.ClassNotFoundException: kawa.standard.Scheme
… 19 more

My guess is, you have the same issue as Tony…


i guess so, kinda similar problem as @Tony_Lange faced. If i add Label component, the apk size little bit smaller and unable to open, but if i remove some, the apk size is little bit bigger and able to open. Not sure what kinda bug is this, perhaps @Kodular would like to clarify. Thanks

i SOLVED my problem, as i said earlier i was copied and modified the component, then i only renamed which is visible component or component i gonna use for the block.

i was having a component named like example:
Space4_copy_copy_copy2_copy_copy2…, and so on.

Little did i know that it may cause the app not completely built as @Tony_Lange argument (discussable), so i rename all components i have on each screen to appropriate name and shorter name.

Voila!!! it works.
Lesson: don’t just use DRY (Don’t Repeat Yourself) on your block, but also on your components name.

Note: above is my stats using, the way i do to my app may worked to you if you have smaller or bigger project.

i’m not sure if this the real solution, thus i would like to keep this topic open so that other who encounter similar issue can discuss here and wait for someone responsible to tell that long component name really affect the built apk.

Special Thanks to people reply on this topic before, appreciate it. @riadaska @Taifun

Its a crying shame that someone from Kodular hasn’t commented as this waiting for “comments” is a lot like flyin in the dark.

It would be so easy for someone from @Kodular to answer your question

Hi @Tony_Lange, haven’t seen you for a while…
do you also use these type of “naming conventions” in your project?


If yes, then it would be a good idea to clean this…


cleaning has NO EFFECT.

I went throught my entire app, cleaned all the copy(s) and it still does NOT COMPILE FULL SIZE OR RUN!

Have you checked it through the component block just to make sure nothing left:



It Works for me

Nice one, can you share here your .aia summary using this link:

I had the same problem, and it was also SOLVED when I changed the long names to the labels

1 Like

One of my projects kept closing the apk even after changing the long names, but it was because it had a notifications extension that was causing the problem, check your extensions and eliminate them one by one until you find the problem.

1 Like