Learn how to create extensions

Is that a must to have JDK? If yes, is that a must to create an account just for that? Cuz I can’t download without it.

Yes.it won’t work without it.

Yes i think you need to create an Oracle account

2 Likes

Hi @Shreyash, I am new to build extension in pc. I did those in appybuilder before.

I used your template and follow all the steps (I used VS code), but there’s so many errors here.

Is this normal?

With the latest version of the extension repo, you need to check out the additional git-submodule that contains the necessary dependencies for extensions. It’s likely you haven’t done this, and hence all those errors. Just run git submodule update --init and you’re good to go.

PS: I’ll update the article to reflect these new changes.

3 Likes

I wasn’t able to run that, or I should run it other where? I ran it in the VS code terminal.

Seems like you don’t have Git installed. Unlike previous versions, this version of extension template requires it.


This one?

Yeah. Or you can install GitHub desktop and it will install Git for you.

1 Like

Thanks! :smiley:

1 Like

Now the result
image
And it’s still not working, unfortunately.

Oh, I know what’s causing it. Follow the below steps:

  • Clone a fresh repo in a new directory using git clone https://github.com/mit-cml/extension-template
  • Once it’s cloned, run git submodule update --init

It’s happening because you’ve downloaded the repo and not cloned it using Git.

1 Like

I cloned once already just now, and now

The image shows it didn’t got cloned as there’s already a directory named “extension-template”. Either rename the existing directory or clone it in a different directory.

1 Like

Okay, I kind of understand. After cloning, I do Git Bash here in the cloned folder. I run the git submodule update --init

And it is asking this

I have clicked OK before, and it asks again

What happens if you type “yes” and hit “ok”. If it still doesn’t works, I’ll suggest you to ask your question here:

This post was flagged by the community and is temporarily hidden.

1 Like

I am getting this error

C:\Users\DELL\Documents\GitHub\extension-template\src>ant extensions
Buildfile: build.xml does not exist!
Build failed

I am using IntelliJ Idea.
Right clicked on .java file and clicked on Open Terminal.
Typed ant extensions and pressed enter.
Got this error.

You should type the ant extensions command in the extension template folder, as I know.

2 Likes

Thanks :smiley: It works.

1 Like

i am Getting Both the Issues as @WatermelonIce (i am getting 24 Errors) and @sonumohammad333 (Build failed - build.xml does not exist!) Pointed /Got.

And i Tried to Resolve Both of them.

But i am Not Able To.

Can Anyone Guide me Step By Step; i am Very New with all this Setup.
:sweat_smile:

1 Like