Open Another Screen block Not working

Check your scree name

1 Like

Checked screen names a couple dozen times. :sweat_smile:

Created a new project with 2 screens, one button per screen.

Here are Screen1 blocks:
Screenshot from 2020-09-05 14-46-03

Same blocks for Screen2:
Screenshot from 2020-09-05 14-46-28

No other code or buttons in the project.

Neither button changes screen.

Can you send an aia?

Swapped from Samsung S6 to S9. Still no joy. But I noticed it was switching very quickly from Screen1 to Screen2 and back to Screen1. :crazy_face:

Screenshot from 2020-09-05 15-21-28

Screenshot from 2020-09-05 15-21-46
So I took out the “Close Screen” blocks and now the open new screen works in both directions.

However, I went back to my S6 and it still doesn’t switch screens.

How can the open another screen block possibly work functionally differently for two different phones?

Included .aia for TestOpenScreen project. Thanks for your help!
TestOpenScreen.aia (3.0 KB)

it should work.That really sounds strange! Can you send a test aia?

Sorry, I added to last message late.

TestOpenScreen.aia (3.0 KB)

1 Like

Try building your app and see what happens on your s6…

To avoid this, use this blocks instead.



Building an APK and downloading it to my S6…worked! :grinning:

Of course, the whole point for my use of the S6 is to test my design and blocks on the fly.

Is there a reason the code works for the APK, but not the Creator? :unamused:


Using the S9 with the Companion, the problem did go away with your suggested blocks.

However, the S6 is still problematic. Using the companion, it will NOT switch screens. :pensive:

I have been using block coding for a couple of years. I have wasted 6 hours on this one open screen problem. My point is that I have a fair amount of experience and I could not get it to work, even after reading docs and a guide and then a suggestion from a moderator. And it still doesn’t work for one of two similar Samsung phones. I’ve created a few apps and this is the first time my S6 has had a problem like this. Besides size, an S6 and an S9 are almost identical in execution.

Can you imagine what goes thru a newbie’s mind when trying to switch screens?

Seems to me that there should be a method to navigate from one screen to another without all this hassle. I was using another vendor and they have this:

Screenshot from 2020-09-05 16-06-12

I don’t recommend that vendor, but it least their “navigate to” block works flawlessly.

Another thing you may try is to clear data and cache from companion app on your s6.

Thanks for your help, btw.

Removed everything I could find regarding Android and Makeroid under Device Storage. Cache was empty.

Fired up Companion, opened Test menu, selected “Connect via USB”, hit Internal Error Cancel button 15 times and the TestOpenScreen project appears on my S6.

Fails. Opened Screen2 thru Screen selector, that button fails as well.

Frustration builds in this one. :confounded:

No issue at all on a Galaxy S6 with Companion (Android 7).
switchScreens.aia (3.1 KB)

Never used usb connection and thereby can’t help you, usb is probably the culprit


Yes, neither do I, as it doesn’t seem to work on my PCs / notebooks (win7, win10).
In AI2, I almost always work with Companion via USB.

1 Like

Btw, no problem to switch the screens in AI2 with Companion via USB connection (S6).

Thank-you for your help. :smiley:

What software version are you running on your S6, if you don’t mind my asking?

Running TestOpenScreen.aia:

MIT AI2 via USB works perfectly on my S6
Thunkable via USB works perfectly on my S6
Two Kodular projects via USB do not work on my S6. Still does not switch screens. :pensive:

S6 via MIT AI2 Companion, works great. Connects and switches screens.
S6 via Thunkable Companion, works great. Connects and switches screens.
S6 via Kodular Companion, no work good. Back to the Error 1103, Unable to Post…etc. :confounded:

I mean, if it’s an Android level or some such, what is the minimum requirement for Kodular?

My Samsung S9 works via USB and Companion, but it’s not really mine, belongs to my wife and she won’t let me have it except on weekends and evenings. :roll_eyes:

Please read my posts carefully:

Sorry, I missed that. :drooling_face: My S6 is running 5.0.2, which may be the problem. I can’t update the S6’s Android version as I don’t have a SIM card for that phone; been using it strictly to test apps.

My solution was to cry and whine until my wife offered to buy me another phone. I have an S8 on the way. :money_mouth_face:

Thank-you Anke, you helped me immensely. :joy:

1 Like

I think you don’t need a SIM card to update Android.


If it isn’t the missing SIM card, I dunno what it is.

I’ve gone to System Updates and selected Software Update Download. I’ve downloaded the Update 4 different times.

Says Software Update ready to install.
I press Install now.
S6 restarts.
Galaxy Screen (teal) comes up with Android robot.
Android robot falls over with an exclamation point sign on his head.
S6 restarts without update.

Any hints?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.