OutOfMemoryError while using REAL DEVICE

This video was sent to me by a user, and other users have also reported it… Basically the app doesn’t open and gives a memory error according to Playstore reports. I applied several recommendations that I found in this community but I haven’t managed to fix it yet. I would appreciate if you could help me find the solution, thank you very much in advance.

Attached are more details of the problem.



Interchange the mentioned above blocks.

You are closing the screen before opening the other screen which is incorrect :roll_eyes:

1 Like

Here in the community I found someone who said that this was the right way to switch between screens.

this is the official solution


Still not working : (

sorry for the audio, forget to mute the video xd

you might want to check tip 2 here


compressed all project images and replaced them in kodular … still not working

So do you want @Cristopher_Toro to open screen first and then close screen?
The blocks are correct as mentioned by @David

Maybe…but not the only solution.
These are also correct (in fact best):

  1. image

@Cristopher_Toro As the issue only occurs on Nougat and I have no nougat device so I can’t get the logcat.But still I shall try to produce issue on Lollipop.
Please post the logcat here if possible.

Thanks for replying, do some research on the logcats but I don’t know how to do it in my app … I am something new in this :sweat_smile:

You can check this topic:

1 Like

was the first to check, likewise thank you very much

Each of these vertical arrangements had a background image, so I have removed them. and it already opens the application, but now I have other errors.

works perfectly on my cell phone

That can happen sometimes in companion if it is working in real device then I think your problem is solved.

1 Like

it is not companion, it is installed in the nox emulator

Yea so it may be related to that if it is working fine in real device then most probably your problem is solved.

1 Like

Real device!

why they have changed the title of my post, in the description I have said that several users have reported that error to me, I also show a screenshot of the Google play console where you can see that the error not only happens to me using the emulator !! !!