Permissions for sql lite component

is it necessary to add Read/write permisions if u want to use SQL lite component or it is built in?

Have you tested it? I did a test in Companion mode … I didn’t do it as an apk.

1 Like

Yeah m trying it. firstly, it was working fine but now it is showing an error that something wrong while quering when i run select query
But still works fine for create, insert queries.

Note : i tried aia from original post of this component then create my own but bow facing isuues in both cases
I deleted my aia and reuploded from its original post even then it showed the very same errror
i tried by deleting darabase too but not worked

I didn’t use an extension. I only did the Create Table if not exist, Insert into and Select from Table. Everything is OK.

1 Like

M not using any extension m using original component too but both of them showing the same error
I think whike working with them something has been changed in my storage files in phone storage that’s why its happening because it worked fine for me tooo but now its showing error

I didn’t change anything …

These inexplicable mistakes are very boring

Wait m preparing an examplary aia then i’ll post

1 Like

sqllite.aia (3.1 KB) this is my aia still showing the very same error
Please have a look into it if i made anything wrong? or its an error relating to component or kodular etc

u can see error in screenshot

Strange, it works here…

1 Like

then what’s wrong!!! i have even tried it with delete database and rebuilding the datbase too but not worked

I used Raw Query - Sql - Selection Args … but your AIA it works here…

It worked but now its showing as the database is empty and i have tried after inserting data many times but still showing this (see error in ss)

I used :
Procedure Call Insert table Columns Values
Procedure Single Sql Sql - to Create
and Call Raw Query - Sql - Selection Args - to Select

I’ll try it… But now tired and gonna sleep its 12:22 am here so goodnight
Me vs errors
In my case every single error and bug thinks that it is its by birth right to irritate me once in life :unamused:

If you are asking for help, I recommend you to make it as easy for others to be able to help you …
You probably will get more feedback then…

which means in your case post a screenshot of your relevant blocks…

To download the aia file, upload it to App Inventor, open it, do some bug hunting for you, etc… this takes time, and most people will not do that…
Thank you.


my problem was solved i used SQL lite extension instaed of component
this extension has more functionality Yet another SQLite extension (Free)
Now m facing another problem that is related to list item seperation as this is completely different from this thread so m gonna create a separate topic for that

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.