Please help to solve: Cannot read properties of undefined

Error generating Yail for screen 5248902859063296_Screen1: : Cannot read properties of undefined (reading ‘indexOf’). Please fix and try packaging again

show like this.

Welcome to the community. If you wish post aia here to check it

Two people are reported the same but none shows theri blocks

Missing parameters in most probably causes the error.

1 Like

ca (2).aia (5.7 KB)

aia file

Try this

ca_1.aia (5.7 KB)

1 Like

thanks for helping

1 Like

Problem solved ? If yes mark solution :white_check_mark: in order to help others

Try this, no firebase errors, compiles ok

ca_2.aia (5.7 KB)

thank you please tell about where to get token of cloudDB

Please if this problem solved mark solution and create a new topic regarding cloudDB. Thank you


You guys should explain how you solved this problem because others have the same issue, and just taking someone’s aia to recode doesn’t actually solve the problem for others.

1 Like

locateveryone.aia (1.4 KB)
please fix this (error generating Yail for screen 4696413231382528_Screen1: : Cannot read properties of undefined (reading ‘indexOf’). Please fix and try packaging again. what is this error & how fix it ?)

Welcome to the community. Missing project properties. Try

locateveryone_1.aia (1.5 KB)

, how did you fix it may be i will help somebody

ShareYourLocation.aia (34.7 KB)
and this one please please

WheresTheBus (1).aia (42.6 KB)
can you fix this please

ShareYourLocation.aia (34.7 KB)