Problem with wifi component

I am trying to receive the IP address but the component does not return anything.
The funny thing is that it worked perfectly and I didn’t change anything.
I did some testing and besides the IP other information is not being returned, such as SSID.
I can receive the MAC, activate and deactivate the wi-fi, among other things.
I have already requested the necessary permissions, but Android does not ask me for authorization either.
Does anyone know anything that helps?

Please create a small app to show the issue.
Also show your blocks.

1 Like

I hope it helps!
Before my device upgraded to Android version 10 it worked perfectly.

which means, it is an Android 10 issue…

if you have some time and you like to do me a favor, yu could test the wifi extension together with your Android 10 device… 2 test projects are already available there… thank you…



Great Taifun, it’s an honor to be able to collaborate, I don’t do it anymore because I don’t feel competent to do so.
I imported your extension and the wifi.aia project, packaged it and installed it on my device.

Enable: working
Disable: working
Get local IP: working
Get SSID: “”
Get BSSID: “02: 00: 00: 00: 00: 00” (would it be the AP’s MAC address? It’s weird.)
View configured SSIDs “()”
Get MAC address: working
Get Connection Info: working
Is 5Ghz band supported: working
Get signal strength: working
Get IP address of access point: working
Get DNS servers: working (even reported IPv6 DNS)
Connect: working (I connected to a network that was not configured on my device providing the ssid and password)
Disconnect: working
Remove: “false” (I tried different ways, connected to the network, disconnected from the network, but the answer was always the same)

I am grateful to be able to help.
If you need anything else that I can help, just say so.

thank you very much for your tests

just drag a location sensor component into the project and additionaly ask for the permission ACCESS_FINE_LOCATION

EDIT: this should also fix the issue in the wifi component…

Starting with Android 8.1 (API 27), apps must be granted the ACCESS_COARSE_LOCATION (or ACCESS_FINE_LOCATION ) permission in order to obtain results from WifiInfo.getSSID() or WifiInfo.getBSSID() . Apps that target API 29 or higher (Android 10) must be granted ACCESS_FINE_LOCATION .

taken from

see the documentation :

Remove a SSID from the network list. Note: starting from Android M, apps are not allowed to remove networks that they did not create.



The missing permission “android.permission.ACCESS_FINE_LOCATION” will be fixed at next release.


I am having the same issue with WiFi component.

I can’t get BSSID, enable or disble WiFi in my phone (Android 10), But I can with my tablet (Android 4.4).

All the permissions needed were granted.

Any idea to solve that ?

EDIT: to get BSSID on Android 10 still works in my wifi extension App Inventor Extensions: WiFi | Pura Vida Apps

starting from Android 10, this method does not work anymore, see also this stackoverflow answer.


I already tried with your extension Taifun, but it always returns “02: 00: 00: 00: 00: 00”