Recast • Make your old extensions compatible with Kodular Fenix

Please anyone :pray: make a guide video how to install recast and extension convert old to new…


You don’t need to, the install script does that for you automatically.

thank you, I meant how can I specify the path to the extension in the program

Oh, okay. You can specify the path to the extension using the --input option. The path can be absolute, or relative to the directory in which the terminal is open currently.

For example, if my extension is at C:/Projects/extensions/io.shreyash.phase.aix and my terminal’s current working directory is C:/Projects, then this is how I’ll specific the path:

recast --input extensions/io.shreyash.phase.aix

Same error occurred

Recast success but when i imported extention into kodular then kodular showed error "import extentions failed ,Uploaded file does not contain any component definition files.

How to fix this?

1 Like

Have you read above posts ?

thread 'main' panicked at 'called Result::unwrap()on anErr value: 87', src\

I Am Getting This Error On My PowerShell

Can you show me your input and output options?

This is what i am getting. I am on windows 7 with powershell 5.x

Are you sure your Windows installation is 64-bit? Recast doesn’t yet supports 32-bit Windows.

1 Like

Yes Its windows 7 ultimate SP1 64 bit

and Powershell Details

Name                           Value
----                           -----
PSVersion                      5.1.14409.1005
PSEdition                      Desktop
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.14409.1005
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3

Can you try running Recast using Command Prompt (CMD)?

I tried same error

thread ‘main’ panicked at ‘called Option::unwrap() on a None value’, src\
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Im getting the same error, and im on windows 10, and it is 64-bit

Can you send me the extension that you’re trying to recast?

Im trying to recast many extensions together which is in a folder

It’s cn.kevinkun.KevinkunEnhance (1).aix that causing the problem. Send it to me.

1 Like

This post was flagged by the community and is temporarily hidden.

It has space in the name