Reduced Screen1 startup time

Silver, I just call it an arrangement that I call a splash in the initialize. I don’t use a timer or a counter for that. However, other arrangements that are not called and are hidden have slightly slower procedures. Even if these procuredures are not called, can they impact the initial application load?

I tried on 3 different cell phones and all the initial charge time is very long.

Are those device support Android 9 or? Mine android 8 take so long also. But in some cases you might consider the device version also…

I need the application to run on android 6 or higher.

No, if it is not called it won’t impact the initial application loading.

Can you list everything you have tried so far to solve this problem?

you can also follow this guide:

1 Like
  • I removed all the arrangements that were starting with a timer. Now there is only one that is visible and has a button in the middle to trigger the rest of the processes.

  • I removed the package name

  • I have few images in the asset and all do not exceed 40kb added. I don’t use any image directly, I call the image only when I use it.

I don’t know how to use logcat so I know which block is overloading the process.

I have a data dictionary that I load at the beginning. Can this type of variable affect the load time?

disable those two blocks and test your app…

It did not decrease anything to disable the blocks.

you have to now, so we can get a better understanding of this issue so we can help you :upside_down_face:

I will try to install and understand how logcat works.

1 Like

this will help you now and for future :slightly_smiling_face:

1 Like



It might be due to tiny db, if you are using tiny db to compare values like to compare user sign in status, in this case sometimes tiny db takes time.

1 Like

I was able to install and connect the logcat. The difficulty now is to discover / understand what is delaying the entry. I posted a comment to show where the initialize block is. As the log starts to run as soon as we click enter on the command line, it theoretically took from my click to start the app to the commented block about 7 seconds. I believe the app started right from line 36 of the log. It took about 5 more seconds (from line 1424) before I see the home screen run and I click the crtl + c from the log. I have the impression that there is a looping occurring at the beginning but I cannot understand exactly where and why it is occurring.

logcar01.txt (238.7 KB)

reboot your device, switch off WIFI and run your app.

after that report back the results

There was a small improvement. The time until the screen appears is now 9.52secs.

logca02.txt (242.0 KB)

do you have any download procedure in your app?