Runtime error on start .apk with BLE

I have created an app to drive my soon’s RC car . the app is working nicely when launch using the companion, but when launched from the .apk I got immediately the following message ‘’ runtime error : Not connected to a bluetooth low energy device - end application’’

looking at some similar topic I have but all my button/ slider to disabled at start, but still have the message… so I don t know what to change more… see the code below.

Thus, why it is working with the companion and not the .apk?

by advance, thx

Since it worked with companion I can only guess that you haven’t granted permission in your app…

Hi Boban,
It was not requesting anything during the installation.
But I just had a try allowing position and storage (the only ones I can check on for this app), but it didn’t change the runtime message error problem …

Are you using the latest one MIT App Inventor + Internet of Things

In Your Phones Settings , Go To Apps , And There You Open Your App’s Permission’s And Enable The Permission… Hope It Works! :grinning:

Yes I m using the latest BLE version (Had some discussion about it on another post in MIT community forum)

@ Dattaraj: already tried but it didn’t change the problem

Try by adding ask for permission manually


ok, I just tried :

I added the permission manually
compiled/ downloaded /installed the app
giving the app full permission (position and storage)
then starting the app and…
I still have the same runtime error AND a new message error 908 saying the permission to fine location has been denied …

I m using a android 6 phone btw

Sorry I really don’t know what may cause the error on your side as I just tried with latest extension build and it automatically asked for permission.

Try Installing The Apk. On Other Device…

ok, well, my mistake, my BLE extension was not the latest release one (lost during the migration from MIT to Kodular… ). Now it is for sure: So this solve the permission problem (error 908) but I still have the runtime error at the start…
To what I understand It is expecting a BLE connection straight to the start: it cannot be linked to the part :
''when bluetoothLE.String.receive … ‘’ ??

@ Datta: the only other device that I have arround is apparently a a fake android9, were BLE is not working at all :frowning_face:

please hlp