* SOLVED * Kodular Companion hangs at “20 Establishing Secure Connection”

I test all common browser. With and without extensions. Clear the cash, disable firewall, try all community hints and tipps …. and, and, and …. nothing works.

Here is my solution:

Download a OLD portable Firefox-Version (i.e. 60.01) from https://mozilla-firefox-portable.de.uptodown.com/windows/versions and install on USB-Stick. Important: Disable Update/Autoupdate. Allow all Cookies. (When using a old browser, it’s a good idea to do that in a sandbox! (i.e. Sandboxie))

Tested with Galaxy S9 and QR-Code Scan. (Not tested with USB yet!)


System: Win10 pro


But still why to face problems when AI2 already has fixed the issues.
Migration can never be a solution.( Chrome > Opera > Edge > Brave > Firefox)
There is more than required inconsistency.

1 Like

Because Kodular is not updated to the latest AI2 merge, therefore you will have to wait until whenever the next major release of Kodular is.

I am still on the safer side because you know the reason.

I don’t even know what you mean by “the safer side” or “you know the reason.”

I use AI2.

Even if you do use AI2, there is no such thing as “the safer side.” There is nothing that compromises your experience when using Kodular besides a simple issue which will be fixed in the coming weeks/months. No security implications, whatsoever.


I don’t understand why they ruining this best platform by not updating it, for so long. on play store everybody is rating 1 star because of this issue. moderators pls do something. Btw portable version showing QR code only.

There is an update that will likely be out in the coming weeks to fix the issues currently happening and bring much more to make the platform even better than before. By rating the Companion one star, you are leaving no choice, but to make it seem as if the platform itself is bad.

1 Like

Problem not solved for me …facing same problem .
Firefox 60.0.1
system - win10
mobile - asus zenfone 5z
Usning QR code

I have the same problem, I already downloaded Safari and FireFox Portable, I use Edge, FireFox and Chrome and no solution for me. Does anyone know any browser that works?

You can use Firefox with the solution provided here


Thanks :100:, using QR-Code It works

have you tried a OLD Firefox-Portable-Version? (i.E. ver. 60.01)

it works :grinning:

1 Like


I actually downgrade my CHROME browser to Version 86.0.4240.75. And then it works fine. As for firefox, I used the security.ssl.enable_ocsp_must_staple SET TO FALSE.
Hope this helps

1 Like

It works fine, thanks.