Unable to Share File with Sharing Component

Yes this is on android 11 so wait till the bug fix is released

Hello Aditya!
Thank you very much for the information, truly appreciate it.

But the problem is not about the information you have provided.
My problem is about the Sharing component, I think it does not matter what the file format is, whatever it is, it is only be able to copy to the internal storage but unable to share it (share dialogue is ot showing), please refer to my first post above and the videos for details.


Mine Too Sharing Btn Not Working !!

I think problem is with path. Try changing it.
I’m not sure which path will work, try changing it to file:///

Hello Chandan!
Thank you for the response.

I successfully share the file with Companion but not with the exported app, I think I have successfully defined the path by that but somehow the app is unable to show the dialogue of sharing component nor sharing the file.

But I will try your solution soon, I will post the result too.


1 Like

Whoa, may I know how do you make the UI to be dark?

It is available in settings.
First button, right-top

Thank you!

I still have this main problem though, if anyone knows how to solve, please let me know.

Try this:

1 Like

Hello Chandan,
Thank you for the help!

I have changed the value of the Sharing component’s block as below

I, then, tried the APK I exported in my phone, please refer to the video below for the outcome.

The outcome shows that it successfully copy the file from assets to internal storage, but again, the Sharing dialogue is not appearing, thus I am unable to share the file.

Hi there!
Thank you for your response.

I have tried your solution after you submitted your response, I arranged the blocks as follows

Note : I have granted the storage permission

The blocks is not exactly the same as yours though, since I am having problem with the Sharing component only.

I, later, exported the APK and tried it on my Android device.
It successfully displays the Sharing dialogue!

Thanks a million for your help! :grin:


Kodular continues to have issues.

I am trying to save an xlsx file in my app’s private directory (ASD).

According to the kodular documentation of the savefile component it says: if the file starts with / (slash) it can be saved in sdcard/myfile.txt but if it doesn’t start with / (slash) the file can be saved in the private folder (ASD).

the problem is that if I save my file with /myfile.txt the file is saved in (ASD) and if I save it without / (slash) is lost I don’t even know where it is saved and therefore the sharing component is not working for me.

the component savefile is doing everything backwards, the test was performed on android 11.

Captura de pantalla (8)

otherwise if I save the file with / (slash) now if it is saved in the private directory (ASD), but the sharing component does not work for me giving the path file:///storage/emulated/0/Android/data/com.myapp/files/myfile.txt for example.

I did another test on adroid 8.0 and the savefile component works fine as the documentation says, but the sharing component still doesn’t work there.

that private folder is NOT the ASD…

If the filename does not start with a slash, it will be written in the programs private data directory where it will not be accessible to other programs on the phone

To store it in the ASD use an extension, for example


1 Like

maybe the solution for now is to add taifun’s share extension, but I’m in a challenge of not using too many extensions and instead trying to use native kodular components.

make some changes.

this is the result file is not created.

another test in this test the file is generated in the specific directory, but the path to share the file is wrong.
Captura de pantalla (10)

this is the result

another test in this test the file is generated in the specific directory, here it seems that everything is correct but it does not show the dialog box to share.
Captura de pantalla (10)

In the first error message you can see, that the path appears twice, I.e you do not need the ASD block there

In the second error message you can see, that the path is missing, i.e. you need the ASD block there

The third example seems to be fine


correct, in the third example it seems that everything is going well, but the dialog box for sharing is not displayed.

the test was done on Android 11.

Try the sharing extension App Inventor Extensions: Sharing | Pura Vida Apps


1 Like

Fixed issue with fenix update 1.5.1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.