Unable to upload using FTP

Out of curiosity I tried it yesterday and today again and it seems to work some what sporadically, some of the components return results or none at all

There are extensions for FTP that cost a buck but since I have no use for this component at the moment, I don’t want to buy one either just to test that it works

If you really need FTP then I recommend Taifun’s App Inventor Extensions: FTP | Pura Vida Apps, even though I haven’t tested it for myself I have noticed that his extensions work better than built-in components.



I just tried again and it work. You ar enot saying what error message is comming up, you are not saying what is working or not.

The ey to FTP is make sure you conect and then disconnect when you are done

Here is what works.

  1. Image Picker to select an App. First thing I do after picking is connect to FTP. You will see if Have a connection status notification. if it connects OK it will give me a notifier OK, and if it is False it will give me an notifier. For debugging I then show the path to the selection in a textbox.

  2. When the upload is done, you see I get a notification that it is done, and then it make a button visible,. Notice I also DISCONNECT.

  3. I then click the now visible button and dan download the image. Notice the syntax. When download is done, I then disconnect AGAIN and show the now downloaded image in an image component.

If you have a problem, WHERE IS IT? It is very tricky to try to spend all this time and help if you are not being clear about the problem.

Hi @cian
I have picked the image and the notifier shows true for connection, but nothing happens after that.

Then I think you have a network issue. FTP needs two ports to operate. 20 and 21.

20 is the data port, and 21 is the connection port.

I have tried it in companion and downloaded APK. It works. So the component works.

Please can you tell me how can I check or reset / correct them?

From your desktop/laptop on the same network you are using your mobile device to test with try to manually connect to the FTP site and manually upload the file.

There are many google examples for that

I think you are correct, I am able to connect from my laptop command prompt but while uploading I am getting no data connection.

So is there any other way I can change ports.

Nope. However You can try by connecting to a vpn.

That will create a tunnel to allow all traffic through.


I’m having the same problem: I have a host with a database. I want the app to take pictures of students and send it to the remote server. This photo will be associated with the student. I use a DELL notebook + wi fi + Companion (on motorola MotoG 7). The error is: file: /storage/emulated/0/Pictures/app_inventor_1555553677.jpg (No such file or directory). What can it be ?


I found it not the problem from the network, as I am now able to upload the files from Control Panel over same network without VPN
It may be bug in FTP component, not working on some devices and @Kodular may fix it soon.
Hope so…

You may use @Taifun 's post file method to save images to server.
I am also using it right now


try this app and see if it works

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.