V1.0.5 Exoplayer for AppInventor | Play media with Google's Exoplayer

Hello @zainulhassan

It might be that I have found another bug or you are aware of this problem/bug is that I was playing a video with your player and after 15:30 minutes the brightness automatically decreased to lowest it’s like the phone is going to sleep…
Then I have tried with another video and the other video is doing same after 15 or 15:30 minutes the brightness decreased to lowest

And I found another bug is that when I have watched video more than 5 minutes and want to seek backward then I tap on the back button but it’s not going backward it is going to forward, both buttons are doing same thing only seeking forward, the backward button is not working properly,I request to check whenever you are free…
Please check both buttons are they doing right.beacuse I m getting this issue in every video… { I m using link to watch if u need link I will give you for test}
I think you have to check that

@zainulhassan
I found another problem or you can say bug:-

When I m watching a video in landscape mode then I rotate my device to potrait the video freezed for 3-4 seconds and then when I rotate my device to landscape the whole player screen becomes black and subtitles and audio coming perfectly but video is not showing after 5-6 seconds video playing good…
Try to solve this problem also…

your player does not work after returning from lock screen or from foreground . this is very bed experience for a user . if user lock there phone while watching a video or he just foreground the task for some time , after that if he want to play again the video , player does not work . please solve this issue . i remind you about that many times . but you never respond to that. it is useless if this bug present . the same bug is also present in deephost exo player.

2 Likes

Is it possible to replace the icons given by you to some other ?

1 Like

Yes you can change the icons. But you need to use the exact name as in the given zip folder.

1 Like

Yes ur right…
And I have getting another problem is that when I m watching a video the phones brightness automatically decreased to lowest and my phone went to sleep…
I have tested this extension in my all devices and I m getting this issue in every phone even I have changed settings of phone sleep mode to never…
My phone even sleeps when I m watching a video…
And @funnymomentforever have told problem that when phone automatically sleeps and when we unlock the phone and try to play video and tap on play/pause button it did nothing, so need to exit from app and restart it again to watch a video after it when I have watched video more than 5 minutes the brightness decreased and phone went to sleep…
Same procedure happening in every phone
This is a serious bug!!!

@zainulhassan please fix this issue…
And I have a advice for you first check and test the extension correctly before publishing to community…

This extension have lot of problems and bugs and the dev doesn’t reply for reported problems…
I have reported many problems but he stopped replying

This sleep problam can be solved using " keep screen on true " block . You can find this block in screen properties . Use this block .

How can I fix the problem if I locked my phone and unlock it then play/pause button didn’t work more specifically the video stopped and player didn’t respond…
And same issue happens when I m playing a video and I want to switch to another app when I switched to another app and again switched to video player it stopped working…

Same issue happens when I tap on home button and then when I open video player it stopped working…

This post was flagged by the community and is temporarily hidden.

Keep calm everyone. I am trying to fix the issue. @funnymomentforever If you have that mush issue, then why not try and fix it yourself. afterall the project is open source. Its easy to talk than to do it by yourself.

1 Like

we just want a reply .

You have commented earlier that If anyone of us found a bug then we can report to you about the bug, we have reported many bugs and you have stopped replying to me and you always said that solve bug by ourself…
What is this DEV…
We just want from you a simple reply that will you fix the bug or not…(as simple as that)…
But you always get unhappy when we report bugs and you say, fix it yourself…

@zainulhassan
Features:-
(Requested Features​:point_down:)

  1. Add support to 10Bit videos…

  2. Direct Google drive Video link Support (Means we can play video with google drive shareable links)(This feature is available in Deephost’s exo player extension)…

  3. Casting (Means cast media to android tv or fire tv stick if Chromecast option is available in tv)…

  4. Autoplay ( when media load from link it should automatically play, no need to tap on play button)…

  5. HLS/M3U8 link quality changing option…

  6. Add support to DASH/MPD streaming links…

  7. Add support to almost all type of video and audio formats( So we no need to convert video to another formats)…

  8. Add aspect ration option in video player UI under settings button…

  9. Add decoder options like HW/SW/SW+

  10. Pop Up play

  11. Video player UI lock(To stop/Prevent accidental touch)

  12. Add Audio delay option ( This option is necessary if the video and audio is not synchronised so that by using this option we can change the speed of audio eg- increase or decrease the speed of audio only)…

  13. Audio boost option ( by using this option we can increase the audio from 100% to 150% or 200% → this option is available in VLC media player)…

  14. Bottom margin for subtitles…(option in blocks or player UI to customise it)

  15. Adding subtitles from video player directly( by using this option we can add subtitles from video player’s ui - this option is available in VLC player)

  16. More customised UI/UX

  17. You can add more options from your side…

Add these options in next update :pray::pray:t2::pray:
@zainulhassan

1 Like

How much you can pay for these features ?

1 Like

Taifun

6 Likes

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

These should work fine. Did you get any error?


This has nothing to do with exoplayer.


Autoplay is already available.


Hopefully in the next update


Already supported


No more changes in the ui will be added. If you want to customize ui, you can do so by editing the ui library provided as open source.


You can customize bottom padding for subtitles.


Maybe in the next next update.


The UI is already very customizeable. It can’t go any further.

2 Likes

@zainulhassan

Thankyou for your reply…cos you are not replying to my comments for sometime…
Great Developer…
I will surely donate money to you…
For now I m collecting amount for you from my colleagues…

Yes I m getting error in 10Bit videos…
I m using HEVC 10bit video…

When I add the media into the player, the player didn’t respond just the progress time loaded and nothing to do after that also the play/pause button didn’t responding after loading 10bit videos…

Here I m leaving some links to 10bit videos please see them and tell what is the problem behind 10bit videos not loading and don’t say that 10bit videos only supports in MP4 format…
I have seen almost all videos in 10 bit coming with mkv format…

Here is the links:-:point_down::point_down::point_down:

https://app.animatev.workers.dev/0:/WEB-SERIES/LOKI%202021/Loki.S01.E01.720p.10Bit.WEB-DL.Hindi.5.1-English.HEVC.x265-HDHub4u.Mx.mkv

And please don’t overuse these links because it can cause my server down…:pray:

1 Like