Web Component works in live test but does not work after installed on the phone

This is part of the research …

Taifun, follow the hardcopy of the cell phone screen with the message of the resquest content and the request code.

how did you test? A device together with the companion app or using an emulator?

I used BlueStack by USB to test. For a productive environment, I downloaded it and installed it on my phone. This photo is from the app installed on the phone and it is giving the error.

On BlueStack does the app run on your smartphone mirroring?
Clear cookies in your Browser.

Rogerio, it is not mirroring, it runs directly without the need to emulate.

Then, clear your smartphone browser cookies.

Rogerio, unfortunately it didn’t work.

In the browser in the development environment on your computer it works. When on the smartphone, no. So theoretically, running in the development environment without bluetstack, right on the smartphone, will also give an error. OK ?

ok, you used an emulator for your tests
let me suggest you to use an Android device together with the companion app to test…
let us know, if you still get the error there…

is the API designed to run on mobile devices? any link to the documentation of the API?


I’m a beginner with Kodular. Can I emulate my phone directly or do I need an intermediary application? If so, which emulator could I use?

Did you follow the reasoning? Have you tested using it only with Companion? Was there an error?

I understood your reasoning. However, I need to emulate the cell phone directly with the companion. Bluestack does not emulate my cell phone, it has its own environment. I need an emulator. Which do you use?

The companion is installed on your smartphone and it connects to the Kodular Creator and the app runs on your phone. I don’t use an emulator. Sometimes I use mirroring.

Wow, now I get it. I will install and perform the test as you suggested. :slightly_smiling_face:

This is Companion
In Kodular Creator, go menu Test

Rogerio, I tried to connect via kodular starter but it didn’t work. I tried to download makeroidstarter but my anti virus did not allow it. I will try to find out how to solve this problem related to access. I have applications created in thunkable and work, but this is not working on Kodular. I will try to understand why. I am very grateful for your help and your patience.

Rogerio, summary of the saga. I gave up triggering the service url directly from the web component. I created a call from the same url in a PHP pgm. I pass the parameters through the web component. I’m actually creating an intermediate layer in PHP to call the same URL. So it worked. I will close that item. Thank you.

I didn’t understand how you solved the problem: it worked on the emulator and the apk installed on the smartphone didn’t work.

Rogerio, I spent the night trying to understand and found out that, in fact, my URL string was passing wrong information to the server. At the end of the string, I had to put the current time and the format was wrong. I think I can close the item. In addition, I found that bad request 400 can occur if the app does not resolve https (SSL). In case someone is experiencing this problem, it is interesting to remove the “s” from http.

1 Like