Webradio App: Doesn't work in Background

I tried all settings (including all battery optimization settings) on a Galaxy Note 8, API28 without success.
The important setting is: “KEEP WIFI ON DURING SLEEP” and this has gone (in Android 9).

Use a web viewer. The web radio will continue in background

This does not help at all, it is due to the WiFi connection, which is interrupted in sleep mode on some devices.

And what happens in this case with other apps? Like whatsapp or telegram? They run in background and are listening if have new messages to notify…

Translated from German:
“I have the same problem. I’ve been struggling through the forums for days and can’t find any suitable solutions. For me, Whats App and GMX are affected.”

I confirm closing the application after a few minutes.
Tested on EMUI 8, 9, 9.1, 10. (Android 8, 9, 10)
Setting “no saving battery” give nothing.
All other settings do nothing.
I had to add the screen turned on permanently to use the radio.
Unfortunately, Kodular has it and nothing can be done.

Yes, but eg on a Samsung Galaxy 8(+) with Android 8 and on a Pixel XL with 8.0 there should be this setting “Keep WiFi on during sleep”:

As I said, this option is no longer available on a Samsung Galaxy with Android 9.

In Huawei is available. It also gives nothing. The application stops working after a few minutes regardless of the system settings.

Does this only happen in sleep mode or even when the app is in the background (e.g. the home button was pressed)? How long does it take after the device has switched to sleep mode before the sound stops?

This happens regardless of the screen being turned off. Just use another application when you have not turned off ours. It will also be turned off after a few minutes.
I never counted that time. It takes from a few to several minutes.

Exactly it happens… the app freezes some time after the screen turned off…

and grafik doesn’t help?

so… i have a galaxy S8 with Android Pie… i don’t have this option… :confused:

Yes, and that’s exactly the problem since Android 9, as it was confirmed in my tests and described in the forums. Unfortunately, there seems to be no way to fix this issue yet.

same problem face

its internet problem but some time depend your mobile performance

Hello to all.

A friend talk with the @Taifun and he developed an extension to solve this: Extension to request IGNORE BATTERY OPTIMIZATIONS. Remember: this will not help to run your app in the background!

PS: This solved this problem, but the in Google Play this option is only allowed to some cases.


Sorry not on one of my test devices, see here:

So post the APK, I will check this …

So… I have a Galaxy S8 and with this config the problem solved… I have the original ROM in Android 9.

1 Like

I checked this again several times. It definitely doesn’t work on a Galaxy Note8 (Android 9) when screen is off (in standby / idle mode) and I’m pretty sure it won’t work on an S8 (Android 9) either. Otherwise, please show the power options (battery settings of your device ) so that I can test them on my device.

I was able to largely prevent the problem of stuttering and later stopping by triggering the grafik every 500 ms with a timer.
But the app still stops after 6-20 minutes; cannot be predicted. And if you bring the app to the foreground, the app is stopped (the play button) shows: “Play”.

So let my test app (Screen1 and Screen2) run for 20 min and report.
ExoPlayer_test2.apk (5.9 MB)



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.