WebView without permission to Filesystem and upload

I have created by collecting infos from different sources (e.g. MIT AI) to realize my WebApp running a chatsite of our club.
Everthing goes fine but I have trouble with permission to filesystem for upload any media and files to the website.
I extended my pack by CustomWebView1 and FileTools
The App runs but when I click on the button to open the file dialogue I get error from android "Error 601: No corresponding activity was found "

Can anybody help me to get this finally working and find out what I am doin’ wrong?
I am a totally newby to this.

Can you show the blocks?

This is what I have actually

1 Like

The issue here is that sometimes mime type returned is empty so you need to check it before setting activity starter’s data type.

The mimetype for sure is ampty because I want to open the file dialogue, and in that moment die mimetype cannot be already filled.
How can I do the check.

Using an if else statement.
Like this:

Basically I have three things to be solved:

File upload
File download
And in case I use the keyboard the app must shrinking to top that I can see the input field above
the keyboard. I not have to type blindly.

I am close to the point I give up playing with this and learning JAVA.
I modified my blocks as you provided and now I do not get shown the website anymore.
I have an empty container now.

Thanks for your patience.screenshot2

Strange…send an APK.

I am also not sure if this is all I need for it.
I need a Webviewer to only show the website with the needed permissions to the filesystem etc.
record voice by mic
cam access to upload image

and one problem left with the android keyboard overlapping the lower part of the webview that I have to type blindly. Actually I solved this on the webpage by moving up the unput-div on top of the keyboard if is mobile.

AQUACHAT.apk (6.1 MB)

Can you clarify whether custom webview is working or not?

Maybe it is important:
The uploads in the website are done with Ajax Uploader and PlUpload.php in chunks to have no limits in size.
But I do not think that this is causing the problems.
In standard Browser all works fine

Everything was going fine with the standard webViewer untill I wanted to upload things.
I switched to customWebviewer and it worked also without the upload things. And then I tried to add the filesystem access things coming to the state above.

My problem is, that I have not that knowledge with his kind of app creating.
I am a php backend programmer and only wanted to pack the webchat in a webview App
to get it native for installing as an app.
So I cannot follow up all questions and hint you give to me.
I do this for our aquaristics and ornamental fishbreeding club

it is actually not working with the above constellation in blocks and the apk I sent.
This apk is corresponding to the block diagram above.
The website is not shown with this, since I added your hints/blocks

Let me check it.

Thank You very much.

Something is wrong in blocks.
Can you share the AIA? Either here or in PM.

AQUACHAT.aia (262.1 KB)