YAIL compiler - ApkBuilder failed - DownloadToASD

Ok, before anyone replies to “thoroughly search the community” for solutions, I think I did do my research about this error.

And I found a couple of reasons causing the error. One of which is due to conflicts between some files in the extensions I use. And I found this to be causing a problem for me. So here’s what I found.

I have a no. of extensions I use (given below).

Before adding the last extension ‘DownloadToASD’, everything was fine. (no offense to the maker of extension). I was able to compile and generate the apk file. After adding the extension I started facing this error. So as per what I found, I tried removing it and recompiling, and as expected, it works fine. To conclude, I think the error is because of conflicts between extensions.

The reason I need to use this extension is to store images and mp3 files in the app-specific directory. I need help in determining which all extensions are causing these conflicts, so as to remove it or another solution to storing data in ASD. I currently use all the extensions given above, in the app. I could have done trial and error, but the app is very big, and removing each extension and working it out is not practical for me right now. This was meant to be an update to what’s already out in the play store. It would be helpful if someone had any ideas or suggestions regarding the same.

I don’t think this extension is conflict with any other library maybe the issue is different

Ok, I am looking for alternative problems causing this error

Okay, so after a bit of trial and error, I found that two extensions when used together are giving rise to my problem. They are Phase animations extension
io.shreyash.phase.aix (81.3 KB)
and the DownloadtoASD extension.
DownloadToASD_notifHidden2.aix (7.6 KB)
I tried with a sample aia, by adding each extension individually and then compiled them as apk. It works fine. But when used together and compiled, it gives the error I mentioned above.
Here’s the aia I tried with.
Tech_Farm.aia (97.5 KB)

@bodymindpower @Shreyash I need to use both extensions for my project. Is there any solution to fix this problem? Or is there any idea what might be causing the error?

Sorry if I am violating community rules by mentioning individuals and extensions in my post. It is to catch their attention.

@mjssakuruppampady Updating the Phase extension to version 2.2.2 works just fine to build.


Thank you, I had tried it earlier with the same version, but that was the direct download extension and did not make any change. Now I tried the google drive downloaded extension and it solved the problem. :v:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.