Admob Ads not getting displayed (even test ads)

Learn to debug your app by yourself with a tool like logcat.
And then you will see the reason why your app does not show ads.


But before updating ads working fine it’s stop after update


Then test your ad Id in android Studio or any other builders and see.if it’s working. If it’s not then it’s Admob’s problem

Absolutely right!:triumph:

Yes bro i downloaded admob tool apk to test my ads. In this app ads are running

1 Like

Yes i check already its working problem is not with My admob
Problem is in @Kodular but Hope That @Kodular Fix ot ASAP


there is a major bug in kodular new update and I don’t know why kodular doesn’t want to except the bug


i have uploaded the bug in app while trying to show ads…hope kodular will fix it ASAP

Are you getting ads after publishing on play store ?

i have not published it to play store so far but i will publish it in 2-3 days

i am not getting ads even without uploading on playstore.

1 Like

If you think there is an issue about ads then let Kodular staff see logcat, so staff can understand the problem. But looks like you all doesn’t want to fix the bug. Ok, you all wanted that. Then your ads won’t work until seeing real error report. That’s it.

Sorry but, you are not helping with saying “AdMob not working”, “this is Kodular bug” etc. And stop repeating the same word every time.


I published my app on play store now ads aren’t getting show​:triumph:

1 Like

Hi guys,
I found a little solutions.
First of All dont load Admob banner ad on INITIALIZE event of screen.
to load banner ad use timer.
write admob.load in timer event

then in ADLOADED event of banner ad use .visible TRUE

But it takes more than 40-60 seconds to load ad.
Thats why you will get less impressions and maybe INVALID impressions.

As per @Mika check this admob help forum!topicsearchin/google-admob-help-forum/error$20load$203

Thank you for this detailed info. There has been a ‘No-Fill’ issue at the google’s end and I think it has been resolved now.

However, I am still not able to see the ads as google mobile ads SDK team said, there were no requests fired from the app. My ad-units are working fine as they checked it using their tool. I am getting ads properly in the development build which means the ads requests are firing properly. But still not getting any ads in production as the requests are not being fired there.

I am following up with Google Mobile Ads SDK team for the same, but wanted to post the same here to know if anyone else got the same reply or people at Kodular know something about this strange behavior.


Same error :disappointed_relieved:

I think the problem has been resolved now. The ads are now visible on both dev and production. Only thing is that they take time to appear which I hope @Kodular will fix at its earliest.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.