Admob Ads not getting displayed (even test ads)


This started 2-3 days back (probably 4-Feb-2019). I was working on an app which easily showed banner and interstitial ads in companion as well as exported apk, suddenly stopped showing any ads. Earlier they were getting displayed but not now (I tried with Banner and Interstitial).

I have recreated the issue in a simple app.
#The app has only 1 screen with an Admob Banner Ad, a button and a label.
Design View

Blocks View

Here, even test ads are not getting loaded on screen initialize in companion and apk.
On button click, the test gets loaded in companion, while the apk install makes the label as Not Loading.

There is one more issue with buttons which started with this problem. Let me know if I could explain the same here or start a new topic.

Note: All previously exported (before 4-Feb-2019) apps are working fine (No button or Admob issue).


I have also same problems, My education app which have 67000 download ,doesn’t load ads after 4 Th february…


I think, you can upload a previous apk to play store (exported before 4th feb) for the time being.

Try that and tell if you see a test ad…


Tried. Not working. No Test Ad.

Then it is no problem with the admob component.
Because the test apk works perfect for me.
Then it’s a problem on your side.
Maybe connection or device problem? I dont know

Is the apk you sent latest?
Because i tried your apk in other devices and it is not working anywhere.

I would suggest you to please try again in some other device because i am not the only one facing this issue.

And this issue has occurred since 4th feb. All apk exported after 4th seems to have this issue.


If a ad is not working anymore then the reason is that we block ads if the app content is not allowed like porn or else.

My existing app is a word game. The new sample code i mentioned in my query is a simple enough code. None of them working. Nothing objectionable.

Please check this apk. Not running in my devices. Contains “load banner” on screen initialization and on button click. MyFirstApp.apk (5.0 MB)


Was working yesterday not anymore

Same here my two friends also having this problem


It is a main isse for admob components that there is no ads load. If we send 100 request, it only showed two or three ads. Almost more than 300 people send me mail and messages for this same issue.

1 Like

I am also facing admob problem after kodular release 1.3B.0 before that on release 1.3 admob ads was working was perfectly.

I m getting following error message under Ad Failed to load block

Interstitial ad was not ready to be shown. Make sure you have set AdUnitId and you invoke this after LoadAd.

I think no one here is out of mind to wrongly set Ad Unit Id. I think this problem is in kodular not from admob.

Please advise


Then do what the message tells you!

Write this to admob!
And then let’s see if they write anything helpfull back to you.

Admob have no ads? NOT KODULAR PROBLEM!

Done so many times as per the message. But same result ads not showing. I have also tested my ad unit ids with Ads Toolbox app. Result comes perfect, as ads showing.

Any help.


Same to you?

Any solution?

I think you have used wrong block .
Show your ads when intertial get loaded. And you are using when screen initialize load ads and show ads.(wrong) For more information search forum for guide to implement admob in kodular.

i have a same issue

the solution is
1st when screen intialize call banner 2 load
2 when banner ad loaded - set banner visible to true.

i hope this will work.