Admob Ads not getting displayed (even test ads)

bug

#21

The error message tells you exact the solution!
Why does nobody anymore read things?!?


(Mudit Agrawal) #22

I would like to ask people posting other issues and random solutions to at least try the code mentioned at the start of this thread.

  1. Create an app with Admob and a button component.
  2. On screen initialize, load admob component.
    OR
  3. On screen initialize, load admob component and when ad loaded, then display admob component.
    OR
  4. Load admob component on button click.
  5. Check the app in companion and using apk after exporting.

This is hardly a 5 min task for everyone. You would know that there is something wrong. Many others are facing these issues.


(Admire Developers) #23

No error message at all but ad also not loading. my test ads are also not loading in every old project.


#24

Show your blocks and app content …


(Mudit Agrawal) #25

Just going through other threads, I found that there is a new admob protection layer added by Kodular. This might be the reason of ads not working. Please tell the steps to whitelist our apps so that they start showing the ads again.


#26

(Mudit Agrawal) #27

What are the criteria that our apps did not pass this blocking system ?
How to whitelist our apps ?

Could you please check this new blocking system as to why it is blocking simple and non-abusive apps too like word games and educational apps. We could make changes to adhere to the new guidelines.


(Muhammad Ghazanfar) #28

I am getting the same error.


#29

Nudism, porn and all like that.


(Abdul Jabbar) #30

I am attaching aia file, simple admob interstitial and banner ads.

As per the below trouble shooting link i am not getting any error or adload failed message nor admob loading, nothing happen.

admobbox.aia (153.0 KB)

Please check and advise. Understand that kodular have implemented admob content restrictions.


#31

Please add here a test apk. Not only aia.


(Mudit Agrawal) #32

Well, as per my initial query, which has only admob, button and label. It should have worked right? That too isn’t working means a bug in the latest update.
I suppose, the new blocking system requires revisiting/debugging as it is blocking almost everything.


(Abdul Jabbar) #33

admobbox-test.apk (5.6 MB)

Please check apk file for testing. When it runs it shows blank no error msg nor admob loading etc.


#34
2019-02-07 13:07:38.029 22002-22014/? I/Ads: No fill from ad server.
2019-02-07 13:07:38.030 22002-22002/? W/Ads: Failed to load ad: 3
2019-02-07 13:07:38.031 22002-22002/? I/AdMob Banner: onAdFailedToLoad

Here is your result…

W/Ads: Failed to load ad: 3

As per the Documentation you are getting the following error code:

public static final int ERROR_CODE_NO_FILL

The ad request was successful, but no ad was returned due to lack of ad inventory.

Constant Value: 3

And this means again:
This is no KODULAR bug!


(Mudit Agrawal) #35

Please check these too.
MyFirstApp.apk (5.0 MB)
MyFirstApp.aia (1.9 KB)


(Buta Singh) #36

Run time error
Index:1 size:0
Internal error when ads load


(Muhammad Ghazanfar) #37

i am facing the same issue since 4-feb-2019. After the new update. And developers of kodular not considering this issue seriously.
Now i found a solution.
solution is to rewrite the app from start.


(Philipp Lang) #38

and delete and upload the aia again does not help too? If this really helps to make a new app, than it should work also to delete the app and upload the aia again. or load all screen into the new app


(Azizul Bashar) #39

2nd one made by kodular <a class=“attachment” href="//kodular-community.s3.dualstack.eu-west-


i think kodular bugs. please fix the bug.


#40

Please provide the apk where you get this Error @developerandoid70
And show too the aia