Apk cannot open

Hi i’m new user of makeroid, and then after i build my apk and i try to open it but it said “Apk not compatible with current system”. At the begining i think its because of minimum sdk but i already change it but it still show that dialog and message. Hopefully anyone can answer it :frowning:

1 Like

Which android Version does your device have?

i have android versi 5.0 and also 5.1 but i also already change the minimum sdk to 4.1 but it still have the same issue

Please send here the apk.

BalibuVisions (5).apk (3.8 MB)
CERPENKU.aia (155.6 KB)

it was the AIA and APK file.

and this is the SC from my phone


I can install the apk without any problem.
Btw is the app really created with makeroid?
Because it looks for me like done with thunkable.

no, i never use thunkable, to build Apps, Actiually this is my first Apps using Makeroid, my last app created using Appbuilder, but because Appybuilder always error when i try to acces it, so i decide to build Apps using Makeroid, so i build this App at Makeroid from the begining, but when i wanna test it using companion, Makeroid Companion not response it, so i decide to try with build it as APK, but when i export it and try to install it to my device it got error, i already try with two different device but it give me a same error. Do you know what is wrong with that ???

Which min sdk uses the project?As I said the apk works for me without problems

sorry it was a wrong apk that i send to you. This is right the APK
CERPENKU (5).apk (2.3 MB)

the Apk that i send before is the APK that i build using Appybuilder and it work find when i export and install it

At the first i build with android 5.0 when i got the error i change it to android 4.1 whic is the very lower version at the option

I Also try to create a new project and i do not change anything and just export it, and when i install it, it also have the same erro

Open the project again and export it again.
Something with your apk is wrong.
And yes the first apk was created with appy builder.

Btw have you imported the aia from appy builder into makeroid?
If yes recreate the project with makeroid.

1 Like

I already do it, but it still have the same error. I Already Build it seven time but the all apk still have sam error, maybe you can check my AIA file ?

Have you used any exclusive component from AppyBuilder which is not available in Makeroid?
For example, their AdMob components are not compatible

No, everything at the app is create using Makeroid. There is nothing from Appybuilder or thunkable . I also already try to create a new project and not changing anything and it just white screen 1 but when i export it and try to install it to my device, it showing the same error.

Is there any such components such as Fingerprint Scanner or other stuff which are incompatible with your phone inside the app?

i think nothing, because i just use a simple component like label, button, and more.

Maybe you want to check my AIA file ?
CERPENKU.aia (155.6 KB)

Hello.
are you trying your projects on an emulator or on a real device?

If you try projects on an emulator (like Memu or Nox) sometimes they do not work …

i try it on an emulator and also on a real device, but the result it same, it was have error. Thats why I really confuse.

Can you maybe try to open my AIA and try to export it, because i really confuse, its really just happen to me or maybe to other one

Why do you use a image with 563width x 807height as icon?
I’m sure this is the reason…

EDIT:
Yes it is the reason.
I removed it in your aia and was able to install your apk on my device.

4 Likes

Great Mika!
number 1!!!:muscle:t3: